summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 14:30:06 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commit781945784e40422dc96214e72ca67a92cab2e6f6 (patch)
tree931e01761f85332bb91f95b2ae467e7a886d2dee /gnu/packages/python-xyz.scm
parent1f892e09b3a8b211a8f6fd5b4caac6c3128035e9 (diff)
gnu: Add python-dbus-fast.
* gnu/packages/python-xyz.scm (python-dbus-fast): New variable. Change-Id: Ie3bfdf71c74bff59067c0b49554e77de0d7bbc49
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4c6a284886..b5cf77698a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38866,6 +38866,23 @@ profile. It supports:
Currently, Linux is the only platform supported by this library.")
(license license:expat)))
+(define-public python-dbus-fast
+ (package
+ (name "python-dbus-fast")
+ (version "2.30.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dbus_fast" version))
+ (sha256
+ (base32 "1cx71lbw716smpr4vsc9d421v45s36hcqj2z95nl3wm2yhan6ac7"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-cython python-poetry-core python-setuptools
+ python-wheel))
+ (home-page "https://github.com/bluetooth-devices/dbus-fast")
+ (synopsis "Faster version of dbus-next")
+ (description "This package provides a faster version of dbus-next.")
+ (license license:expat)))
(define-public python-clrprint
(package
(name "python-clrprint")