summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-22 20:40:27 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:30 +0000
commit5c5398bd48bcb76bc5302994a1f974612122c259 (patch)
treee14b3ea4640d4658573ec918b7c4c880208c6c3b /gnu/packages/python-xyz.scm
parent84f7bbddf14f03557946e40e9410eef9a8e0e8f1 (diff)
gnu: python-stack-data: Update to 0.6.3.
* gnu/packages/python-xyz.scm (python-stack-data): Update to 0.6.3. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Add 'set-home-env phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Iec506c94451618ad32610f0a3302d8d2fe00f18f
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8ecd82bf15..a8f3e91df2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13276,22 +13276,34 @@ functions, useful in the context of writing unit tests among other uses.")
(define-public python-stack-data
(package
(name "python-stack-data")
- (version "0.2.0")
+ (version "0.6.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "stack_data" version))
(sha256
- (base32 "04lfcj5qrn4qikjw89qbdzqwm0xm4bgm4m8rll1rafk3pm0jssa5"))))
- (build-system python-build-system)
- (propagated-inputs (list python-asttokens python-executing python-pure-eval))
+ (base32 "1fgh900z6g1amb2f2ql461c1y8lazymxi7nqvk8xri7ywj6pfsl3"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'set-home-env
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
(native-inputs
(list python-cython
python-littleutils
python-pygments
python-pytest
+ python-setuptools
python-setuptools-scm
- python-typeguard))
+ python-typeguard
+ python-wheel))
+ (propagated-inputs
+ (list python-asttokens
+ python-executing
+ python-pure-eval))
(home-page "https://github.com/alexmojaki/stack_data")
(synopsis "Python stack frame and traceback manipulation library")
(description "The @code{stack_data} Python library extracts data from