summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-17 22:21:29 +0000
committerRicardo Wurmus <[email protected]>2025-01-20 21:38:04 +0100
commit3ce9151a0303fde5a410596e50c8b4cb26f38efd (patch)
tree4361a5f06217dbe16a103b0f7d8e8fcf983ff87b /gnu/packages/python-xyz.scm
parent100efdbd7a5a6db2cbb3214f989d5466c0246af3 (diff)
gnu: python-typing-inspect: Update to 0.9.0.
* gnu/packages/python-xyz.scm (python-typing-inspect): Update to 0.9.0. [source]: Remove patch, as <https://github.com/ilevkivskyi/typing_inspect/issues/60> was resolved. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. * gnu/packages/patches/python-typing-inspect-fix.patch: Delete file. * gnu/local.mk: Deregester the patch. Change-Id: Idc6e8745d4b85624863a5c2dc24e533a7dd92f46
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ccd3d8bd01..e971e36adf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23087,17 +23087,21 @@ Python versions that don't natively support them.")
(define-public python-typing-inspect
(package
(name "python-typing-inspect")
- (version "0.6.0")
+ (version "0.9.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "typing_inspect" version))
(sha256
(base32
- "1dzs9a1pr23dhbvmnvms2jv7l7jk26023g5ysf0zvnq8b791s6wg"))
- (patches (search-patches "python-typing-inspect-fix.patch"))))
- (build-system python-build-system)
+ "0y0z8v4wr5bahlgzjd1il2z8vlfd2asiyb45wia6kvznyqpw8gxj"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(propagated-inputs
- (list python-mypy-extensions python-typing-extensions))
+ (list python-mypy-extensions
+ python-typing-extensions))
(home-page "https://github.com/ilevkivskyi/typing_inspect")
(synopsis "API for inspection of types in the Python @code{typing} module")
(description