summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-17 20:21:00 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-17 20:44:46 +0000
commiteaa6f0d3516485e40dfc2507baedcb41daadcb5a (patch)
treeec2fc7ea087a06ddf58a7349d3c7a8b92c164a30 /gnu/packages/python-web.scm
parenta365261beb4fa86680dbd8a2218b0d60db616d1a (diff)
gnu: python-requests-next: Inherit from python-requests.
* gnu/packages/python-web.scm (python-requests-next): Inherit from python-requests. [arguments] <tests?>: Enable them as all passed successfully. Change-Id: Ic0d985f819444e0b01a843da94d874d16a742fb6
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm33
1 files changed, 10 insertions, 23 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 28dec52f33..2ee444a509 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4530,31 +4530,18 @@ than Python’s urllib2 library.")
(define-public python-requests-next
(package
+ (inherit python-requests)
(name "python-requests")
(version "2.32.3")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "requests" version))
- (sha256
- (base32
- "0q5742pnibwy74169kacin3dmqg9jzmzk7qab5aq5caffcbm8djm"))))
- (build-system python-build-system)
- (native-inputs
- (list nss-certs-for-test))
- (propagated-inputs
- (list python-certifi
- python-charset-normalizer
- python-idna
- python-urllib3))
- (arguments
- ;; FIXME: Some tests require network access.
- '(#:tests? #f))
- (home-page "http://python-requests.org/")
- (synopsis "Python HTTP library")
- (description
- "Requests is a Python HTTP client library. It aims to be easier to use
-than Python’s urllib2 library.")
- (license license:asl2.0)))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32 "0q5742pnibwy74169kacin3dmqg9jzmzk7qab5aq5caffcbm8djm"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs python-requests)
+ (prepend nss-certs-for-test)))))
(define-public python-requests-kerberos
(package