summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-01-14 11:45:24 +0800
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:49 +0100
commitc70738d9b03bbe11782e2395ecbde975155a0d9c (patch)
tree7ceae1d12e2432121f468555406923c303b263ff /gnu/packages/python-web.scm
parent95b390b774a8be3c08a80911935e55a99741a044 (diff)
gnu: python-wsgi-intercept: Update to 1.13.1.
* gnu/packages/python-web.scm (python-wsgi-intercept): Update to 1.13.1. [build-system]: Switch to pyproject-build-system. [arguments]: Disable tests. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I1bfcb902e543eedcaeed3d01ee5996f9b5c96925
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9021f0733f..05c96b8acb 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3221,18 +3221,27 @@ term.js Javascript terminal emulator library.")
(define-public python-wsgi-intercept
(package
(name "python-wsgi-intercept")
- (version "1.2.2")
+ (version "1.13.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "wsgi_intercept" version))
(sha256
(base32
- "0kjj2v2dvmnpdd5h5gk9rzz0f54rhjb0yiz3zg65bmp65slfw65d"))))
- (build-system python-build-system)
+ "1h94dj7h7n7zdj3ll4imqjhq5vk21yidk2niwnmpw7xik9inrgbr"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX: tests required internet access
+ #:tests? #f))
(propagated-inputs
(list python-six))
(native-inputs
- (list python-pytest python-httplib2 python-requests python-urllib3))
+ (list python-httplib2
+ python-pytest
+ python-requests
+ python-setuptools
+ python-urllib3
+ python-wheel))
(synopsis "Puts a WSGI application in place of a real URI for testing")
(description "Wsgi_intercept installs a WSGI application in place of a real
URI for testing. Testing a WSGI application normally involves starting a