summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-12 22:45:37 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:48 +0100
commitb6b7b024674502a13159c92ba98aa689dcdabea7 (patch)
treef288cb1409a2797332c5799f16f05bf7facea5d5 /gnu/packages/python-web.scm
parent08be08901288b0ac6e8a62acf3ea11f5aa0d133e (diff)
gnu: python-flask-httpauth: Update to 4.8.0.
* gnu/packages/python-web.scm (python-flask-httpauth): Update to 4.8.0. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-flask. [native-inputs]: Add nss-certs-for-test, python-pytest, python-setuptools, and python-wheel; remove python-flask. Change-Id: Iae3416cdbc79c2972e2fab6ea2b32fbc02c53499
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index dd9c5f8dd2..9e9f634be3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5822,17 +5822,21 @@ thread-local variable.")
(define-public python-flask-httpauth
(package
(name "python-flask-httpauth")
- (version "3.2.3")
+ (version "4.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Flask-HTTPAuth" version))
(sha256
(base32
- "13gff5w1mqpzm5nccyg02v3ifb9ifqh5k866cssjhghhg6msfjsz"))))
- (build-system python-build-system)
+ "0yh9fn6pak64has89pcy03f1cn198vkil872y5jjr53kph2qlmk6"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-flask))
(native-inputs
- (list python-flask))
+ (list nss-certs-for-test
+ python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/miguelgrinberg/flask-httpauth/")
(synopsis "Basic and Digest HTTP authentication for Flask routes")
(description "@code{flask_httpauth} provides Basic and Digest HTTP