summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-06 17:19:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:37 +0100
commitb3e8c9ce683943420057e9b635046b7500493f33 (patch)
tree0273c8d928d425bf59c5b69c5daa270c5d0dde6b /gnu/packages/python-web.scm
parentb17052496f98aa339105f6d82b5772a09f11ee99 (diff)
gnu: python-webassets: Fix build.
* gnu/packages/python-web.scm (python-webassets)[arguments]: Delete broken tests; run tests with nosetests. [propagated-inputs]: Add python-pyyaml. [native-inputs]: Remove python-pytest. Change-Id: Iee1a38b02770259d11e4c7f6eff5d25c6be52ff9
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 807df8fcc1..f81ec5749a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5623,12 +5623,19 @@ for Flask.")
"self.t.is_alive"))
;; This test requires 'postcss' and 'babel' which are
;; not yet available in Guix.
- (delete-file "tests/test_filters.py")))
+ (delete-file "tests/test_filters.py")
+ ;; These expect pytest, but when pytest is added to the
+ ;; environment more tests fail.
+ (delete-file "tests/test_cache.py")
+ (delete-file "tests/test_bundle_build.py")
+ (delete-file "tests/test_bundle_urls.py")))
(replace 'check
(lambda _
- (invoke "pytest" "-vv"))))))
+ (invoke "nosetests" "-vv"))))))
+ (propagated-inputs
+ (list python-pyyaml))
(native-inputs
- (list python-jinja2 python-mock python-nose python-pytest))
+ (list python-jinja2 python-mock python-nose))
(home-page "https://github.com/miracle2k/webassets")
(synopsis "Media asset management")
(description "Merges, minifies and compresses Javascript and CSS files,