summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-12 21:46:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:47 +0100
commitb2eae674730c719821f36e99d903ed442d227791 (patch)
treefd33cba753aa45bab9416cf9fe495b145c99908c /gnu/packages/python-web.scm
parentd1597a7b02e0e017da73dc9a80ceb17bf6a8c108 (diff)
gnu: python-pynetbox: Update to 7.4.1.
* gnu/packages/python-web.scm (python-pynetbox): Update to 7.4.1. [arguments]: Remove phase 'disable-failing-tests; use test-flags instead. [propagated-inputs]: Add python-packaging. [native-inputs]: Remove python-pyyaml. Change-Id: I2138797ba292ae06985187ec89c2d77e580b0703
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 12 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7d26dd2c78..dd9c5f8dd2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -10260,23 +10260,25 @@ hardware on Grid'5000 or via OpenStack, to Vagrant, Chameleon, and more.")
(define-public python-pynetbox
(package
(name "python-pynetbox")
- (version "7.2.0")
+ (version "7.4.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "pynetbox" version))
(sha256
(base32
- "1pzmkl4nr247v4022i33v32jlx88wwcdy7ycyfd4pnl19vag8d9p"))))
+ "1hq0mqykwdsmcrj61fxxzdkpc7wnld4grhkcxy560ym79jbbb0iz"))))
(build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda _
- ;; Integration tests depend on docker.
- (delete-file-recursively "tests/integration"))))))
- (propagated-inputs (list python-requests))
- (native-inputs (list python-pytest python-pyyaml python-setuptools
- python-setuptools-scm python-wheel))
+ (list
+ #:test-flags
+ ;; Integration tests depend on docker.
+ '(list "--ignore=tests/integration")))
+ (propagated-inputs (list python-packaging python-requests))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/netbox-community/pynetbox")
(synopsis "NetBox API client library")
(description "Python module to query and edit data stored in a