summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-16 21:04:41 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:21 +0100
commitaccf3136a03af88a2717ee78b7b26f25c0ea4597 (patch)
treeebda66d1a161b03741f1fa29c4c182136c7bce37 /gnu/packages/python-web.scm
parent5088b2f998ef9eb524fc3a0b3af87e34d7276797 (diff)
gnu: Add python-pypitoken.
* gnu/packages/python-web.scm (python-pypitoken): New variable. Change-Id: I0e18205ac87be8cc95af80b62c99c087083cef88
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a9fb2a00bf..1edd3256b1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1638,6 +1638,27 @@ content using a variety of algorithms.")
Encryption} (JOSE) Web Standards.")
(license license:lgpl3+)))
+(define-public python-pypitoken
+ (package
+ (name "python-pypitoken")
+ (version "7.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pypitoken" version))
+ (sha256
+ (base32 "18hhwmdfs9y5ypl1n8z2h2ys2f52mv5xr043gzgb34mpmg0wi46x"))))
+ (build-system pyproject-build-system)
+ ;; There are no tests.
+ (arguments (list #:tests? #false))
+ (propagated-inputs (list python-jsonschema python-pymacaroons
+ python-typing-extensions))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://pypitoken.readthedocs.io/en/latest/")
+ (synopsis "Manipulate PyPI API tokens")
+ (description "This package lets you manipulate PyPI API tokens.")
+ (license license:expat)))
+
(define-public python-pyscss
(package
(name "python-pyscss")