summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-10 07:38:59 +0000
committerSharlatan Hellseher <[email protected]>2025-02-10 07:39:13 +0000
commita3437ed164f9a1bb13156e323a470a6f1dcb410e (patch)
tree55725975a993c3e96f336ac052b4dbe39c8e6866 /gnu/packages/python-web.scm
parent4add7827b558533cce4d5f33542088e083c60a25 (diff)
gnu: python-pastescript: Update to 3.7.0, fix build.
* gnu/packages/python-web.scm (python-pastescript): Update to 3.7.0, fix build. [source] <uri>: Adjust the name as it's been changed in PyPI archive. [build-system]: Swap to pyproject-build-system. [arguments] <tests?>: Enable the most of the them. [propagated-inputs]: Add python-setuptools. [native-inputs]: Remove python-nose; add python-pytest and python-wheel. [home-page]: Fix URL. Change-Id: I8584693bf968e8278bdbce3abf43a7cb3b4cd8fb
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 14 insertions, 18 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b4f6da8f02..259d6c51ec 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6565,30 +6565,26 @@ follows ideas flowing from WSGI (Web Standard Gateway Interface).")
(define-public python-pastescript
(package
(name "python-pastescript")
- (version "2.0.2")
+ (version "3.7.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "PasteScript" version))
+ (uri (pypi-uri "pastescript" version))
(sha256
- (base32
- "1h3nnhn45kf4pbcv669ik4faw04j58k8vbj1hwrc532k0nc28gy0"))))
- (build-system python-build-system)
+ (base32 "08959bmp62pb2rlwr4wpwij15y83jcf9wa9jgg32jlvfzf6h4vsk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "--ignore=tests/appsetup/testfiles")))
(native-inputs
- (list python-nose))
+ (list python-pytest
+ python-wheel))
(propagated-inputs
- (list python-paste python-pastedeploy))
- (home-page (string-append "https://web.archive.org/web/20161025192515/"
- "http://pythonpaste.org/script/"))
- (arguments
- '(;; Unfortunately, this requires the latest unittest2,
- ;; but that requires traceback2 which requires linecache2 which requires
- ;; unittest2. So we're skipping tests for now.
- ;; (Note: Apparently linetest2 only needs unittest2 for its tests,
- ;; so in theory we could get around this situation somehow.)
- #:tests? #f))
- (synopsis
- "Pluggable command line tool for serving web applications and more")
+ (list python-paste
+ python-pastedeploy
+ python-setuptools))
+ (home-page "https://github.com/pasteorg/pastescript")
+ (synopsis "Pluggable command line tool for serving web applications and more")
(description
"PasteScript is a plugin-friendly command line tool which provides a
variety of features, from launching web applications to bootstrapping project