summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-02-27 08:10:51 +0100
committerRicardo Wurmus <[email protected]>2025-02-27 09:59:49 +0100
commit9d1b14a6e8b4446709253f5cc2c73aee83e02061 (patch)
tree1b0d79de5f069c69e31ac638160da5548c49bf7a /gnu/packages/python-web.scm
parent0a80a595d3b828487bda7a6afeb1df8b0f7dc8b3 (diff)
gnu: python-aws-sam-translator: Use Pydantic 2.
* gnu/packages/python-web.scm (python-aws-sam-translator)[arguments]: Enable tests that failed due to the use of Pydantic 1. [propagated-inputs]: Replace python-pydantic with python-pydantic-2. Change-Id: I8623da82278465f36339160926853d8410af74db
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index defa2a6c3a..6bc51520d9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1419,16 +1419,6 @@ routes using HTTP Digest Authentication.")
#:test-flags
#~(list "--numprocesses" (number->string (parallel-job-count))
"--ignore=tests/bin/test_public_interface.py"
- "-k"
- (string-join
- ;; AttributeError: module 'pydantic.v1' has no attribute
- ;; 'error_wrappers'
- (list "not test_connector_with_empty_properties"
- "test_connector_with_invalid_permission"
- "test_connector_with_invalid_permission_type"
- "test_connector_without_source"
- "test_transform_invalid_document")
- " and not ")
"tests")
#:phases
#~(modify-phases %standard-phases
@@ -1450,7 +1440,7 @@ routes using HTTP Digest Authentication.")
(propagated-inputs
(list python-boto3
python-jsonschema
- python-pydantic
+ python-pydantic-2
python-typing-extensions))
(home-page "https://github.com/aws/serverless-application-model")
(synopsis "Transform AWS SAM templates into AWS CloudFormation templates")