summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2022-06-22 18:48:00 +0200
committerLudovic Courtès <[email protected]>2022-06-22 18:48:00 +0200
commit8655a714457dbf1cde45979507012d9515614028 (patch)
tree7712625328f45794ccda9baa730a4825bb2efb47 /gnu/packages/python-science.scm
parenta589049e141588ebcf4079116e378d60b779f6b4 (diff)
parent2af3f5eef045f7d177cc394c89be069bac895688 (diff)
Merge branch master into core-updates
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm31
1 files changed, 29 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 855fe9a72c..56f109e3d5 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2022 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2022 Paul A. Patience <[email protected]>
;;; Copyright © 2022 Wiktor Żelazny <[email protected]>
+;;; Copyright © 2022 Eric Bavier <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -182,13 +183,13 @@ logic, also known as grey logic.")
(define-public python-scikit-image
(package
(name "python-scikit-image")
- (version "0.19.2")
+ (version "0.19.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "scikit-image" version))
(sha256
- (base32 "0vc6c78780jivsg79ja0cncn1ma2wysy9fyz97kik0kg59jb8cyl"))))
+ (base32 "0l645smf7w1kail70z8d9r3xmvz7qh6g7n3d2bpacbbnw5ykdd94"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -858,6 +859,32 @@ and more
@end itemize")
(license license:gpl3)))
+(define-public python-pyglm
+ (package
+ (name "python-pyglm")
+ (version "2.5.7")
+ (source
+ (origin
+ ;; Test files are not included in the archive in pypi.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Zuzu-Typ/PyGLM")
+ (commit version)
+ ;; Checkout the bundled `glm` submodule. PyGLM uses the
+ ;; currently unreleased GLM_EXT_matrix_integer feature. Can
+ ;; maybe unbundle once [email protected] is released.
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08v0cgkwsf8rxscx5g9c5p1dy38rvak2fy3q6hg985if1nj6d9ks"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Zuzu-Typ/PyGLM")
+ (synopsis "OpenGL Mathematics library for Python")
+ (description "PyGLM is a Python extension library which brings the OpenGL
+Mathematics (GLM) library to Python.")
+ (license license:zlib)))
+
(define-public python-distributed
(package
(name "python-distributed")