summaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-14 21:37:55 +0000
committerSharlatan Hellseher <[email protected]>2025-02-28 22:44:03 +0000
commit165c090c6143eb8a5d7b7c91d6148e790779f977 (patch)
tree69f217e912adb5bcd34b0d6b610e87e7859a9492 /gnu/packages/python-science.scm
parent7895f144b67775704ec3b2b43c08a9873a113a89 (diff)
gnu: Add python-cmocean.
* gnu/packages/python-science.scm (python-cmocean): New variable. Change-Id: I8b304c0280832f202714df278960493cbd3b12df
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f2a669e7ed..f7990bc9ea 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -174,6 +174,33 @@ scientific codes by steering the implementation towards usability and
maintainability.")
(license license:bsd-3)))
+(define-public python-cmocean
+ (package
+ (name "python-cmocean")
+ (version "4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cmocean" version))
+ (sha256
+ (base32 "0z0d4ma6i228gwpgnkai8scs9bmzz41rirlnqpmb8hazzfcq71ip"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-matplotlib
+ python-numpy
+ python-packaging))
+ (home-page "https://github.com/matplotlib/cmocean")
+ (synopsis "Colormaps for Oceanography")
+ (description
+ "This package contains colormaps for commonly-used oceanographic
+variables. Most of the colormaps started from @code{matplotlib} colormaps,
+but have now been adjusted using the viscm tool to be perceptually uniform.")
+ (license license:expat)))
+
(define-public python-cvxpy
(package
(name "python-cvxpy")