summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <[email protected]>2020-09-23 14:53:44 +0200
committerGuillaume Le Vaillant <[email protected]>2020-09-23 14:53:44 +0200
commit1828958db52d0019a7f3d763b07e64f78afa2cbf (patch)
tree8bdff27c5b3dc088d923e91a14a38f6a6b9fa661 /gnu/packages/python-crypto.scm
parent7e463dd16b7e273011f0beafa57a89fa2d525f8b (diff)
parent23744435613aa040beacc61a0825cc72280da80a (diff)
Merge branch 'wip-lisp' into staging
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 6b81b80860..774d9b3a9f 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -64,6 +64,30 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
+(define-public python-potr
+ (package
+ (name "python-potr")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/python-otr/pure-python-otr.git")
+ (commit version)))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pycrypto" ,python-pycrypto)))
+ (synopsis "Python OTR Implementation")
+ (description "Python OTR is an Off-The-Record Protocol Implementation in
+Python. It does not bind to libotr.")
+ (home-page "https://github.com/python-otr/pure-python-otr")
+ (license license:lgpl3+)))
+
(define-public python-base58
(package
(name "python-base58")