summaryrefslogtreecommitdiff
path: root/gnu/packages/pretty-print.scm
diff options
context:
space:
mode:
authorLeo Famulari <[email protected]>2024-07-11 15:18:51 -0400
committerLudovic Courtès <[email protected]>2024-08-31 10:45:43 +0200
commit8a20f58420ff62cf2e9daeaf88d8ec1dfecb81b4 (patch)
tree009ace8cad65b8fbcdabec4adf88b5ce80ac6b70 /gnu/packages/pretty-print.scm
parent1c322552dd47dbefdd740e2a6750e310840e9244 (diff)
gnu: Boost: Fix a bug that breaks libetonyek.
This fixes <https://issues.guix.gnu.org/72040>. * gnu/packages/patches/boost-fix-duplicate-definitions-bug.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Use it. (boost-for-source-highlight): New variable, not using the patch. * gnu/packages/pretty-print.scm (source-highlight)[inputs]: Replace BOOST with BOOST-FOR-SOURCE-HIGHLIGHT. Change-Id: I5fbc9eb5000aefd7d3a14cc7a0482741032b5400
Diffstat (limited to 'gnu/packages/pretty-print.scm')
-rw-r--r--gnu/packages/pretty-print.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 220761fc07..d8ff1664b4 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -305,7 +305,7 @@ a fast alternative to @code{IOStreams}.")
;; The ctags that comes with emacs does not support the --excmd options,
;; so can't be used
(inputs
- (list boost))
+ (list boost-for-source-highlight))
(native-inputs
(list bison flex))
(arguments