summaryrefslogtreecommitdiff
path: root/gnu/packages/pikchr.scm
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2022-06-08 14:46:24 +0200
committerLudovic Courtès <[email protected]>2022-06-08 14:46:24 +0200
commit8c3e9da13a3c92a7db308db8c0d81cb474ad7799 (patch)
tree88d06952aa5cc3a9c4991d9c43eb7950ff174fe1 /gnu/packages/pikchr.scm
parent5439c04ebdb7b6405f5ea2446b375f1d155a8d95 (diff)
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pikchr.scm')
-rw-r--r--gnu/packages/pikchr.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/pikchr.scm b/gnu/packages/pikchr.scm
new file mode 100644
index 0000000000..5a26b11ac6
--- /dev/null
+++ b/gnu/packages/pikchr.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 pukkamustard <[email protected]>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pikchr)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public pikchr
+ (let ((commit "221988914eff6efe")
+ (revision "0")) ;increment for each new snapshot
+ (package
+ (name "pikchr")
+ ;; To update, use the last check-in in https://pikchr.org/home/timeline?r=trunk
+ (version (string-append revision "-" (string-take commit 5)))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://pikchr.org/home/tarball/" commit
+ "/pikchr.tar.gz"))
+ (file-name (string-append "pikchr-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0yclkincsgfni4scjzp5avdsij8vmyxjn0q2qkwjhn3p43y8nxzd"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "pikchr" bin)))))))
+ (home-page "https://pikchr.org")
+ (synopsis "Markup language for diagrams in technical documentation")
+ (description
+ "Pikchr (pronounced @emph{picture}) is a PIC-like markup language for
+diagrams in technical documentation. Pikchr is designed to be embedded in
+fenced code blocks of Markdown or similar mechanisms of other documentation
+markup languages.")
+ (license license:bsd-0))))