summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-web.scm
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:40 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:19:00 +0100
commit9eaecd260cd42b5f3a9d45aec8b306f921ee628c (patch)
tree5bce957b1118f25fd96b114dcef9c642a79fee75 /gnu/packages/perl-web.scm
parenta1f211c9c5c889174cf7979e5b52d79370606dc3 (diff)
gnu: Add perl-soap-lite.
* gnu/packages/perl-web.scm (perl-soap-lite): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
Diffstat (limited to 'gnu/packages/perl-web.scm')
-rw-r--r--gnu/packages/perl-web.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 459bd43a8a..b4c89d1947 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -190,3 +190,45 @@ picture associated with your email address.")
"Package extracted from SOAP::Lite. Slightly modified to work on
multiple platforms.")
(license license:perl-license)))
+
+(define-public perl-soap-lite
+ (package
+ (name "perl-soap-lite")
+ (version "1.27")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PH/PHRED/SOAP-Lite-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00fkvmnxiy5mr45rj5qmxmflw0xdkw2gihm48iha2i8smdmi0ng3"))))
+ (build-system perl-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "t/Issues/rt53375.t"
+ (("XML::Parser::Lite")
+ "XML::Parser")))))))
+ (native-inputs (list perl-test-most perl-test-warn))
+ (propagated-inputs (list perl-class-inspector
+ perl-constant
+ perl-io-compress
+ perl-io-sessiondata
+ perl-io-socket-ssl
+ perl-libwww
+ perl-lwp-protocol-https
+ perl-mime-base64
+ perl-scalar-list-utils
+ perl-task-weaken
+ perl-uri
+ perl-xml-parser))
+ (home-page "https://metacpan.org/release/SOAP-Lite")
+ (synopsis "Client/server interface to the Simple Object Access Protocol")
+ (description
+ "@code{SOAP::Lite} is a collection of Perl modules that provide a
+simple and lightweight interface to the
+@acronym{SOAP, Simple Object Access Protocol}, both on client and server
+side.")
+ (license license:perl-license)))