summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEric Bavier <[email protected]>2019-01-13 21:08:48 -0600
committerEric Bavier <[email protected]>2019-01-14 15:34:54 -0600
commit974537fc4cd8045bcdce68c5ce79df35b0e17ec3 (patch)
tree5a8b13ab19352cebb4b871d2532c84666b14b7dd /gnu/packages/patches
parent2df4f7020d2c49110900f786af7700d170c3035c (diff)
gnu: python-pycodestyle: Fix build with Python 3.7.
* gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-pycodestyle)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch b/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch
new file mode 100644
index 0000000000..16388c8dba
--- /dev/null
+++ b/gnu/packages/patches/python-pycodestyle-stdlib-tokenize-fix.patch
@@ -0,0 +1,35 @@
+From 397463014fda3cdefe8d6c9d117ae16d878dc494 Mon Sep 17 00:00:00 2001
+From: Michael Hudson-Doyle <[email protected]>
+Date: Tue, 25 Sep 2018 14:58:57 +1200
+Subject: [PATCH] Keep compability with stdlib tokenize.py changes
+
+https://github.com/python/cpython/commit/c4ef4896eac86a6759901c8546e26de4695a1389
+is not yet part of any release of Python but has been backported to all
+versions in Git (includeing 2.7!). It causes the tokenize.py module to
+emit a synthetic NEWLINE token for files that do not in fact end with a
+newline, which confuses pycodestyle's checks for blank lines at the end
+of a file. Fortunately the synthetic NEWLINE tokens are easy to detect
+(the token text is "").
+
+Fixes #786
+---
+ pycodestyle.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pycodestyle.py b/pycodestyle.py
+index 0d725d27..fbc3dca3 100755
+--- a/pycodestyle.py
++++ b/pycodestyle.py
+@@ -258,10 +258,10 @@ def trailing_blank_lines(physical_line, lines, line_number, total_lines):
+ """
+ if line_number == total_lines:
+ stripped_last_line = physical_line.rstrip()
+- if not stripped_last_line:
++ if physical_line and not stripped_last_line:
+ return 0, "W391 blank line at end of file"
+ if stripped_last_line == physical_line:
+- return len(physical_line), "W292 no newline at end of file"
++ return len(lines[-1]), "W292 no newline at end of file"
+
+
+ @register_check