summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch
diff options
context:
space:
mode:
authorAbhishek Cherath <[email protected]>2024-04-20 09:44:03 -0400
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:34 +0100
commit075ff9f60b3b899ab9d2f51c08b9c3528a190a4e (patch)
tree96b02f94f6f2ce6571ca631635f27d9410ea4b77 /gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch
parent5f0c0bc59a34b7e2554c003f8dd42e8591ffdae0 (diff)
gnu: webkitgtk: Expose more paths to bubblewrap sandbox.
Provide access to system locale path and to paths from GUIX_LOCPATH, LOCPATH, and LIBVA_DRIVERS_PATH to the Bubblewrap sandbox in order to silence GTK locale warnings and enable hardware accelerated video. * gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch: Add @dridir@ and @localedir@ to bubblewrap gtk sandbox. Add paths from GUIX_LOCPATH, LOCPATH, and LIBVA_DRIVERS_PATH to bubblewrap gtk sandbox. * gnu/packages/webkit.scm (webkitgtk) [arguments]: In the 'configure-bubblewrap-store-directory' phase, also supply system locale to webkitgtk-adjust-bubblewrap-paths.patch template. Change-Id: I6be0c473ebaa6c04ebb00a2b4afcae2c89396e4f Signed-off-by: Maxim Cournoyer <[email protected]>
Diffstat (limited to 'gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch')
-rw-r--r--gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch b/gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch
index 18ddb645ad..eb2f9e2b68 100644
--- a/gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch
+++ b/gnu/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch
@@ -1,11 +1,13 @@
Share /gnu/store in the BubbleWrap container and remove FHS mounts.
+Also share system locale directory and paths in LOCPATH, GUIX_LOCPATH,
+and LIBVA_DRIVERS_PATH.
This is a Guix-specific patch not meant to be upstreamed.
diff --git a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
index f0a5e4b05dff..88b11f806968 100644
--- a/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
+++ b/Source/WebKit/UIProcess/Launcher/glib/BubblewrapLauncher.cpp
-@@ -854,27 +854,12 @@ GRefPtr<GSubprocess> bubblewrapSpawn(GSubprocessLauncher* launcher, const Proces
+@@ -854,27 +854,21 @@ GRefPtr<GSubprocess> bubblewrapSpawn(GSubprocessLauncher* launcher, const Proces
"--ro-bind", "/sys/dev", "/sys/dev",
"--ro-bind", "/sys/devices", "/sys/devices",
@@ -33,6 +35,15 @@ index f0a5e4b05dff..88b11f806968 100644
+
+ // Bind mount the store inside the WebKitGTK sandbox.
+ "--ro-bind", "@storedir@", "@storedir@",
++
++ // This is needed for system locales.
++ "--ro-bind-try", "@localedir@", "@localedir@",
};
++ // User specified locale directory.
++ bindPathVar(sandboxArgs, "LOCPATH");
++ // Locales in case of foreign system.
++ bindPathVar(sandboxArgs, "GUIX_LOCPATH");
++ // Drivers for video hardware acceleration (va-api).
++ bindPathVar(sandboxArgs, "LIBVA_DRIVERS_PATH");
if (launchOptions.processType == ProcessLauncher::ProcessType::DBusProxy) {