summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tao-fix-parser-types.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-07-24 23:53:17 +0200
committerMarius Bakke <[email protected]>2020-07-24 23:53:17 +0200
commitcbe96f14700f4805552c47d5f163a75c35f86575 (patch)
treed7791d29b283507bb8953a292d764b24774c955c /gnu/packages/patches/tao-fix-parser-types.patch
parent337333c2567bdf767fdc8e04520c4bc0c8b33784 (diff)
parent7a9a27a051a04a7fee2e7fe40127fedbe9112cfd (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/tao-fix-parser-types.patch')
-rw-r--r--gnu/packages/patches/tao-fix-parser-types.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/patches/tao-fix-parser-types.patch b/gnu/packages/patches/tao-fix-parser-types.patch
new file mode 100644
index 0000000000..5dcf3fc2ea
--- /dev/null
+++ b/gnu/packages/patches/tao-fix-parser-types.patch
@@ -0,0 +1,26 @@
+Taken from Debian:
+https://salsa.debian.org/multimedia-team/taopm/-/raw/master/debian/patches/02-fix-parser-yyerror.diff
+
+Description: Use a constant char, dummy comment.
+Author: Tiago Bortoletto Vaz <[email protected]>
+Last-Update: 2013-04-17
+--- a/taoparse/taoparser.yy
++++ b/taoparse/taoparser.yy
+@@ -23,7 +23,7 @@
+ #include <stdio.h>
+ #include "taoparserdefs.h"
+
+-int yyerror(char *s);
++int yyerror(const char *s);
+
+ //#ifdef LINUX
+ int yylex(void);
+@@ -2924,7 +2924,7 @@
+ }
+
+
+-int yyerror (char *s)
++int yyerror (const char *s)
+ {
+ parse_error(what_I_expected_here);
+ std::cout << "PARSE_FAILED";