summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/openscad-with-cgal-5.4.patch
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <[email protected]>2024-08-22 15:30:32 +0200
committerGuillaume Le Vaillant <[email protected]>2024-08-22 15:34:12 +0200
commit6bec6c20b6b18dc173383a6828f1bb84314f986b (patch)
tree4451821834a05e5d8139296570586eca1137e2f5 /gnu/packages/patches/openscad-with-cgal-5.4.patch
parent645cb9b6f609a6e399437d2c76f9b61b8e6dd7a3 (diff)
gnu: openscad: Fix build.
Fixes <https://issues.guix.gnu.org/72693>. * gnu/packages/patches/openscad-fix-boost-join.patch: New file. * gnu/packages/patches/openscad-with-cgal-5.3.patch: New file. * gnu/packages/patches/openscad-with-cgal-5.4.patch: New file. * gnu/local.mk (dist_patch_DATA): Register new patches. * gnu/packages/engineering.scm (openscad)[source]: Use new patches. [inputs, native-inputs]: Remove labels. [arguments]: Disable a few more tests. Remove trailing booleans. Change-Id: I3ce103afd8669dd68c95352a87d76994a3f08504
Diffstat (limited to 'gnu/packages/patches/openscad-with-cgal-5.4.patch')
-rw-r--r--gnu/packages/patches/openscad-with-cgal-5.4.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/openscad-with-cgal-5.4.patch b/gnu/packages/patches/openscad-with-cgal-5.4.patch
new file mode 100644
index 0000000000..f1fedc2cd8
--- /dev/null
+++ b/gnu/packages/patches/openscad-with-cgal-5.4.patch
@@ -0,0 +1,38 @@
+From abfebc651343909b534ef337aacc7604c99cf0ea Mon Sep 17 00:00:00 2001
+From: Torsten Paul <[email protected]>
+Date: Wed, 2 Feb 2022 02:30:59 +0100
+Subject: [PATCH] CGAL build fix, v5.4 renames projection traits header files
+ and classes.
+
+---
+ src/cgalutils-tess.cc | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/cgalutils-tess.cc b/src/cgalutils-tess.cc
+index ec1cc1eeb3..37f8cf08b1 100644
+--- a/src/cgalutils-tess.cc
++++ b/src/cgalutils-tess.cc
+@@ -6,10 +6,12 @@
+ #pragma push_macro("NDEBUG")
+ #undef NDEBUG
+ #include <CGAL/Constrained_Delaunay_triangulation_2.h>
+-#if CGAL_VERSION_NR >= CGAL_VERSION_NUMBER(4,11,0)
+- #include <CGAL/Triangulation_2_projection_traits_3.h>
++#if CGAL_VERSION_NR < 1050401000
++#include <CGAL/Triangulation_2_projection_traits_3.h>
++typedef CGAL::Triangulation_2_filtered_projection_traits_3<K> Projection;
+ #else
+- #include <CGAL/Triangulation_2_filtered_projection_traits_3.h>
++#include <CGAL/Projection_traits_3.h>
++typedef CGAL::Filtered_projection_traits_3<K> Projection;
+ #endif
+ #include <CGAL/Triangulation_face_base_with_info_2.h>
+ #pragma pop_macro("NDEBUG")
+@@ -19,7 +21,6 @@ struct FaceInfo {
+ bool in_domain() { return nesting_level%2 == 1; }
+ };
+
+-typedef CGAL::Triangulation_2_filtered_projection_traits_3<K> Projection;
+ typedef CGAL::Triangulation_face_base_with_info_2<FaceInfo, K> Fbb;
+ typedef CGAL::Triangulation_data_structure_2<
+ CGAL::Triangulation_vertex_base_2<Projection>,