summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/mrustc-patches.patch
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-17 17:20:58 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:15:04 +0200
commit07bdee02778f5b30b341a01de6dd24dfef2fde2c (patch)
treee79ff25c9aa4e362037319830830958bea91ae6f /gnu/packages/patches/mrustc-patches.patch
parent584c79d5dfb10208a9704a01f79af79f7d012544 (diff)
gnu: mrustc: Update to 0.11.0-1.5e01a76.
* gnu/packages/rust.scm (%mrustc-commit): Update to newest commit. (%mrustc-source): Update to 0.11.0-1.5e01a76. Add a patch. Adjust the snippet to not use vendored openssl. (rust-bootstrap)[source]: Remove patch, remove patch-flags. Add to the snippet a substitution for compatibility with llvm-13. [inputs]: Remove input labels. Remove conditional use of clang. [arguments]: Allow parallel building on all architectures. Update the make-flags. Replace the 'unpack phase to unpack the mrustc sources. Delete the custom 'set-mrustc-sources and 'patch-cargo-checksum phases. Adjust the custom 'patch-makefiles phase. Adjust the 'configure and 'build phases to no longer use clang on some architectures. * gnu/packages/patches/mrustc-patches.patch: New file. * gnu/packages/patches/rustc-1.54.0-src.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Update it. Change-Id: I7e444abe4b386b1bb77f05a278ddef45152ddb3c
Diffstat (limited to 'gnu/packages/patches/mrustc-patches.patch')
-rw-r--r--gnu/packages/patches/mrustc-patches.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/mrustc-patches.patch b/gnu/packages/patches/mrustc-patches.patch
new file mode 100644
index 0000000000..626945e2a1
--- /dev/null
+++ b/gnu/packages/patches/mrustc-patches.patch
@@ -0,0 +1,19 @@
+diff --git a/rustc-1.54.0-src.patch b/rustc-1.54.0-src.patch
+index 088c723a..d322fd0d 100644
+--- a/rustc-1.54.0-src.patch
++++ b/rustc-1.54.0-src.patch
+@@ -302,14 +302,3 @@
+ use self::generic as arch;
+
+ pub use self::arch::{vec128_storage, vec256_storage, vec512_storage};
+-
+---- src/llvm-project/llvm/include/llvm/Support/Signals.h
+-+++ src/llvm-project/llvm/include/llvm/Support/Signals.h
+-@@ -14,6 +14,7 @@
+- #ifndef LLVM_SUPPORT_SIGNALS_H
+- #define LLVM_SUPPORT_SIGNALS_H
+-
+-+#include <cstdint>
+- #include <string>
+-
+- namespace llvm {