summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
diff options
context:
space:
mode:
authorPierre Langlois <[email protected]>2021-03-20 21:31:22 +0000
committerLudovic Courtès <[email protected]>2021-03-31 15:36:48 +0200
commit383b02a370252c08eb1d43ac94d659c1d3993a35 (patch)
treedf2419c84e73b0c7b2bfeb5c93061264e34725f7 /gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
parentc536f0b217714917988d2f412999d978c2f2f495 (diff)
gnu: libvirt: Update to 7.1.0.
* gnu/packages/virtualization.scm (libvirt): Update to 7.1.0. [source]: Remove libvirt-create-machine-cgroup.patch, add libvirt-do-not-create-var-dirs.patch. [build-system]: Switch to meson-build-system. [arguments]: Use meson-0.55. Adapt #:configure-flags for meson, there is no need for --docdir anymore. Remove fix-BOURNE_SHELL-definition phase. Add fix-sysconfdir-and-localstatedir phase. Adapt disable-broken-tests to meson. [native-inputs]: Add python-docutils and rpcsvc-proto. * gnu/packages/patches/libvirt-create-machine-cgroup.patch: Delete. * gnu/packages/patches/libvirt-do-not-create-var-dirs.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add new patch, remove the other. Signed-off-by: Ludovic Courtès <[email protected]>
Diffstat (limited to 'gnu/packages/patches/libvirt-do-not-create-var-dirs.patch')
-rw-r--r--gnu/packages/patches/libvirt-do-not-create-var-dirs.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch b/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
new file mode 100644
index 0000000000..6b89d49fd4
--- /dev/null
+++ b/gnu/packages/patches/libvirt-do-not-create-var-dirs.patch
@@ -0,0 +1,30 @@
+We define localstatedir as /var, and so we shouldn't be installing empty
+directories there.
+
+diff --git a/src/meson.build b/src/meson.build
+index f13b85b74e..58040f2c5d 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -893,22 +893,6 @@ if conf.has('WITH_DTRACE_PROBES')
+ )
+ endif
+
+-
+-# Install empty directories
+-
+-virt_install_dirs += [
+- localstatedir / 'cache' / 'libvirt',
+- localstatedir / 'lib' / 'libvirt' / 'images',
+- localstatedir / 'lib' / 'libvirt' / 'filesystems',
+- localstatedir / 'lib' / 'libvirt' / 'boot',
+-]
+-
+-meson.add_install_script(
+- meson_python_prog.path(), python3_prog.path(), meson_install_dirs_prog.path(),
+- virt_install_dirs,
+-)
+-
+-
+ # Check driver files
+
+ if host_machine.system() == 'linux'