summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/jami-fix-esc-bug.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2022-09-17 23:28:45 -0400
committerMaxim Cournoyer <[email protected]>2022-09-23 23:56:15 -0400
commit84369105d4fc8c6f9399e6157112259deada30b8 (patch)
treedd28744f672ad0f6f5c8fe07b117b95e6c50340b /gnu/packages/patches/jami-fix-esc-bug.patch
parent503cfd542124d5e6983c28839953424e44b88244 (diff)
gnu: jami: Update to 20220825.0828.c10f01f.
* gnu/packages/jami.scm (jami): Update to 20220825.0828.c10f01f. (%jami-version): Set to latest release. (%jami-sources): Remove jami-fix-esc-bug.patch; add jami-fix-crash-on-block-contact.patch. * gnu/packages/patches/jami-fix-esc-bug.patch: Delete file. * gnu/packages/patches/jami-fix-crash-on-block-contact.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/jami-fix-esc-bug.patch')
-rw-r--r--gnu/packages/patches/jami-fix-esc-bug.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/patches/jami-fix-esc-bug.patch b/gnu/packages/patches/jami-fix-esc-bug.patch
deleted file mode 100644
index 6d78542f1e..0000000000
--- a/gnu/packages/patches/jami-fix-esc-bug.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-This fixes the issue where pressing the ESC key would hide the Jami
-GUI on systems lacking a notification tray.
-
-From 47fd4c38ddd8bd350319ce9bb750ca496826e655 Mon Sep 17 00:00:00 2001
-From: Sébastien Blin <[email protected]>
-Date: Fri, 29 Jul 2022 21:24:01 -0400
-Subject: [PATCH] layoutmanager: fix popFullScreenItem
-
-Change-Id: I79780d4ad570846e6f3c52734dd627bcd0e11327
----
-
-diff --git a/src/app/LayoutManager.qml b/src/app/LayoutManager.qml
-index 98516ce..87f13ac 100644
---- a/client-qt/src/app/LayoutManager.qml
-+++ b/client-qt/src/app/LayoutManager.qml
-@@ -176,7 +176,7 @@
-
- // Only leave fullscreen mode if our window isn't in fullscreen
- // mode already.
-- if (priv.fullScreenItems.length === 0) {
-+ if (priv.fullScreenItems.length === 0 && priv.windowedVisibility !== Window.Hidden) {
- // Simply recall the last visibility state.
- visibility = priv.windowedVisibility
- }