summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gwenview-kimageannotator.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2024-03-29 12:56:57 -0400
committerMaxim Cournoyer <[email protected]>2024-04-03 18:05:14 -0400
commit4ab5d17e214b7ec20f76e81eb352eb3a74f38660 (patch)
treec28485aa641ea189d4e3918065edad01b215c88d /gnu/packages/patches/gwenview-kimageannotator.patch
parent1757b5bc3ceb7882ac38f5c2b124c2a96fd65625 (diff)
gnu: gwenview: Update to 23.08.5 and fix build.
* gnu/packages/kde.scm (gwenview): Update to 23.08.5. [source]: Apply gwenview-kimageannotator patch. [inputs]: Remove qtimageformats; add qtimageformats-5. * gnu/packages/patches/gwenview-kimageannotator.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Change-Id: If73bc38772adef9f43d74f0f9061dfb2600aa502
Diffstat (limited to 'gnu/packages/patches/gwenview-kimageannotator.patch')
-rw-r--r--gnu/packages/patches/gwenview-kimageannotator.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/gwenview-kimageannotator.patch b/gnu/packages/patches/gwenview-kimageannotator.patch
new file mode 100644
index 0000000000..92b994a0b5
--- /dev/null
+++ b/gnu/packages/patches/gwenview-kimageannotator.patch
@@ -0,0 +1,29 @@
+Submitted By: Douglas R. Reno <renodr at linuxfromscratch dot org>
+Date: 2024-02-26
+Initial Package Version: 23.08.5
+Upstream Status: Rejected (Qt6 port is primary now)
+Origin: Self
+Description: Fixes building Gwenview with recent kImageAnnotator
+ and kColorPicker versions by adjusting their paths
+ and FOUND variables so that the correct libraries are
+ selected.
+
+--- gwenview-23.08.5.orig/CMakeLists.txt 2024-02-26 15:02:29.702754535 -0600
++++ gwenview-23.08.5/CMakeLists.txt 2024-02-26 15:09:48.012866877 -0600
+@@ -166,11 +166,11 @@ if(NOT WITHOUT_X11)
+ endif()
+
+ if (QT_MAJOR_VERSION STREQUAL "5")
+- find_package(kImageAnnotator)
+- set_package_properties(kImageAnnotator PROPERTIES URL "https://github.com/ksnip/kImageAnnotator" DESCRIPTION "The kImageAnnotator library provides tools to annotate" TYPE REQUIRED)
+- if(kImageAnnotator_FOUND)
+- set(KIMAGEANNOTATOR_FOUND 1)
+- find_package(kColorPicker REQUIRED)
++ find_package(kImageAnnotator-Qt5)
++ set_package_properties(kImageAnnotator-Qt5 PROPERTIES URL "https://github.com/ksnip/kImageAnnotator" DESCRIPTION "The kImageAnnotator library provides tools to annotate" TYPE REQUIRED)
++ if(kImageAnnotator-Qt5_FOUND)
++ set(kImageAnnotator_FOUND 1)
++ find_package(kColorPicker-Qt5 REQUIRED)
+ if(NOT kImageAnnotator_VERSION VERSION_LESS 0.5.0)
+ set(KIMAGEANNOTATOR_CAN_LOAD_TRANSLATIONS 1)
+ endif()