summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-hurd64-fault.patch
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <[email protected]>2024-11-16 17:55:21 +0100
committerJanneke Nieuwenhuizen <[email protected]>2024-12-03 08:33:13 +0100
commita9005279d0608f956c95c6852ace27ae69c57201 (patch)
treebe6428d5aae3ed526e24ba328ff376e2ad8ecdd3 /gnu/packages/patches/glibc-hurd64-fault.patch
parentcb765c421846a79d9dae8f0c090cc7e0b85e8d88 (diff)
gnu: glibc/hurd: Add patches for the 64bit Hurd.
These patches fix: * Statically linked tar to hang/segfault upon issuing the "--mtime=@1" warning; this is also applicable for the 32bit Hurd using glibc-2.39! See <https://lists.gnu.org/archive/html/bug-hurd/2024-11/msg00115.html>. * Shell replacement problems for the 64bit Hurd. See <https://lists.debian.org/debian-hurd/2024/07/msg00063.html>. * Findutil's gnulib-tests/test-sigaction failure. * gnu/packages/patches/glibc-hurd-pthread_setcancelstate.patch, gnu/packages/patches/glibc-hurd64-fault.patch, gnu/packages/patches/glibc-hurd64-intr-msg-clobber.patch, gnu/packages/patches/glibc-hurd64-sgms-context.patch: New file. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/base.scm (glibc/hurd): Use them. Change-Id: I9ee65983876cd22ad1dc01aabb41a34074631599
Diffstat (limited to 'gnu/packages/patches/glibc-hurd64-fault.patch')
-rw-r--r--gnu/packages/patches/glibc-hurd64-fault.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-hurd64-fault.patch b/gnu/packages/patches/glibc-hurd64-fault.patch
new file mode 100644
index 0000000000..24980e8c2a
--- /dev/null
+++ b/gnu/packages/patches/glibc-hurd64-fault.patch
@@ -0,0 +1,32 @@
+Upstream-status: Taken from: <https://salsa.debian.org/glibc-team/glibc/-/blob/c36c87acb1a35d6e06db6cef1e28cf2f405e1a9e/debian/patches/hurd-i386/git-fault-64bit.diff>.
+
+See <https://lists.gnu.org/archive/html/bug-hurd/2024-11/msg00115.html>.
+
+commit 11ad033e1c09c8b8e7bbaa72420f41ab8bcf0f63
+Author: Flavio Cruz <[email protected]>
+Date: Tue Jul 30 00:51:20 2024 -0400
+
+ x86_64 hurd: ensure we have a large enough buffer to receive exception_raise requests.
+
+ Message-ID: <gtxd6s4s7fi7hdrlb7zayq3akij7x6jqawwq3zfl3v4nqspulo@euucuzeonrl6>
+
+diff --git a/hurd/hurdfault.c b/hurd/hurdfault.c
+index 5110c6030f..1fe973f54d 100644
+--- a/hurd/hurdfault.c
++++ b/hurd/hurdfault.c
+@@ -121,7 +121,14 @@ faulted (void)
+ struct
+ {
+ mach_msg_header_t head;
+- char buf[64];
++ /* This is the size of the exception_raise request
++ * including mach_msg_header_t.
++ * See generated code in faultexc_server.c. */
++#ifdef __LP64__
++ char buf[112];
++#else
++ char buf[64];
++#endif
+ } request;
+ mig_reply_header_t reply;
+ extern int _hurdsig_fault_exc_server (mach_msg_header_t *,