summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gjs-fix-closure-annotations.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-10-20 13:38:17 +0200
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:33 +0100
commiteef3e925fb9ed5df1bc7ccb9b36c00e5ab914ab9 (patch)
tree47d085732afd44bfb5f77570c7ac39f678ecb84a /gnu/packages/patches/gjs-fix-closure-annotations.patch
parent6056174792ad13d87fc22d8a13790f13d81aea73 (diff)
gnu: gjs: Fix build.
* gnu/packages/patches/gjs-fix-closure-annotations.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (gjs)[patches]: Use it here.
Diffstat (limited to 'gnu/packages/patches/gjs-fix-closure-annotations.patch')
-rw-r--r--gnu/packages/patches/gjs-fix-closure-annotations.patch99
1 files changed, 99 insertions, 0 deletions
diff --git a/gnu/packages/patches/gjs-fix-closure-annotations.patch b/gnu/packages/patches/gjs-fix-closure-annotations.patch
new file mode 100644
index 0000000000..1b440ef9da
--- /dev/null
+++ b/gnu/packages/patches/gjs-fix-closure-annotations.patch
@@ -0,0 +1,99 @@
+From 1df5d72d8df383199dcd88cd1d16209617bf32ca Mon Sep 17 00:00:00 2001
+From: Philip Chimento <[email protected]>
+Date: Sat, 27 Jul 2024 20:17:39 -0700
+Subject: [PATCH] GjsPrivate: Fix closure annotations
+
+Apparently the closure annotation can be omitted if the parameter is named
+"user_data". If it is needed because the parameter is not named
+"user_data" then the annotation should be on the callback argument and
+refer to the user data argument.
+---
+ libgjs-private/gjs-util.c | 10 +++++-----
+ libgjs-private/gjs-util.h | 16 ++++++++--------
+ 2 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/libgjs-private/gjs-util.c b/libgjs-private/gjs-util.c
+index b264aec1e..ae65287f5 100644
+--- a/libgjs-private/gjs-util.c
++++ b/libgjs-private/gjs-util.c
+@@ -235,7 +235,7 @@ void gjs_gtk_container_child_set_property(GObject* container, GObject* child,
+ * @store: a #GListStore
+ * @item: the new item
+ * @compare_func: (scope call): pairwise comparison function for sorting
+- * @user_data: (closure): user data for @compare_func
++ * @user_data: user data for @compare_func
+ *
+ * Inserts @item into @store at a position to be determined by the
+ * @compare_func.
+@@ -258,7 +258,7 @@ unsigned int gjs_list_store_insert_sorted(GListStore *store, GObject *item,
+ * gjs_list_store_sort:
+ * @store: a #GListStore
+ * @compare_func: (scope call): pairwise comparison function for sorting
+- * @user_data: (closure): user data for @compare_func
++ * @user_data: user data for @compare_func
+ *
+ * Sort the items in @store according to @compare_func.
+ */
+@@ -270,7 +270,7 @@ void gjs_list_store_sort(GListStore *store, GjsCompareDataFunc compare_func,
+ /**
+ * gjs_gtk_custom_sorter_new:
+ * @sort_func: (nullable) (scope call): function to sort items
+- * @user_data: (closure): user data for @compare_func
++ * @user_data: user data for @sort_func
+ * @destroy: destroy notify for @user_data
+ *
+ * Creates a new `GtkSorter` that works by calling @sort_func to compare items.
+@@ -305,7 +305,7 @@ GObject* gjs_gtk_custom_sorter_new(GjsCompareDataFunc sort_func,
+ * gjs_gtk_custom_sorter_set_sort_func:
+ * @sorter: a `GtkCustomSorter`
+ * @sort_func: (nullable) (scope call): function to sort items
+- * @user_data: (closure): user data to pass to @sort_func
++ * @user_data: user data to pass to @sort_func
+ * @destroy: destroy notify for @user_data
+ *
+ * Sets (or unsets) the function used for sorting items.
+@@ -423,7 +423,7 @@ void gjs_log_set_writer_default() {
+ /**
+ * gjs_log_set_writer_func:
+ * @func: (scope notified): callback with log data
+- * @user_data: (closure): user data for @func
++ * @user_data: user data for @func
+ * @user_data_free: (destroy user_data_free): destroy for @user_data
+ *
+ * Sets a given function as the writer function for structured logging,
+diff --git a/libgjs-private/gjs-util.h b/libgjs-private/gjs-util.h
+index 7ee83e0d8..11b7c7cbc 100644
+--- a/libgjs-private/gjs-util.h
++++ b/libgjs-private/gjs-util.h
+@@ -124,11 +124,11 @@ typedef gboolean (*GjsBindingTransformFunc)(GBinding* binding,
+ * @target:
+ * @target_property:
+ * @flags:
+- * @to_callback: (scope notified) (nullable):
+- * @to_data: (closure to_callback):
++ * @to_callback: (scope notified) (nullable) (closure to_data):
++ * @to_data:
+ * @to_notify: (destroy to_data):
+- * @from_callback: (scope notified) (nullable):
+- * @from_data: (closure from_callback):
++ * @from_callback: (scope notified) (nullable) (closure from_data):
++ * @from_data:
+ * @from_notify: (destroy from_data):
+ *
+ * Returns: (transfer none):
+@@ -149,11 +149,11 @@ GBinding* gjs_g_object_bind_property_full(
+ * @target:
+ * @target_property:
+ * @flags:
+- * @to_callback: (scope notified) (nullable):
+- * @to_data: (closure to_callback):
++ * @to_callback: (scope notified) (nullable) (closure to_data):
++ * @to_data:
+ * @to_notify: (destroy to_data):
+- * @from_callback: (scope notified) (nullable):
+- * @from_data: (closure from_callback):
++ * @from_callback: (scope notified) (nullable) (closure from_data):
++ * @from_data:
+ * @from_notify: (destroy from_data):
+ */
+ GJS_EXPORT \ No newline at end of file