summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ganeti-deterministic-manual.patch
diff options
context:
space:
mode:
authorMarius Bakke <[email protected]>2020-07-24 23:53:17 +0200
committerMarius Bakke <[email protected]>2020-07-24 23:53:17 +0200
commitcbe96f14700f4805552c47d5f163a75c35f86575 (patch)
treed7791d29b283507bb8953a292d764b24774c955c /gnu/packages/patches/ganeti-deterministic-manual.patch
parent337333c2567bdf767fdc8e04520c4bc0c8b33784 (diff)
parent7a9a27a051a04a7fee2e7fe40127fedbe9112cfd (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/ganeti-deterministic-manual.patch')
-rw-r--r--gnu/packages/patches/ganeti-deterministic-manual.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/ganeti-deterministic-manual.patch b/gnu/packages/patches/ganeti-deterministic-manual.patch
new file mode 100644
index 0000000000..2d90aa740e
--- /dev/null
+++ b/gnu/packages/patches/ganeti-deterministic-manual.patch
@@ -0,0 +1,16 @@
+Sort the ecode list in the gnt-cluster manual for deterministic results.
+
+Submitted upstream: <https://github.com/ganeti/ganeti/pull/1504>.
+
+diff --git a/lib/build/sphinx_ext.py b/lib/build/sphinx_ext.py
+--- a/lib/build/sphinx_ext.py
++++ b/lib/build/sphinx_ext.py
+@@ -108,7 +108,7 @@ CV_ECODES_DOC = "ecodes"
+ # pylint: disable=W0621
+ CV_ECODES_DOC_LIST = [(name, doc) for (_, name, doc) in constants.CV_ALL_ECODES]
+ DOCUMENTED_CONSTANTS = {
+- CV_ECODES_DOC: CV_ECODES_DOC_LIST,
++ CV_ECODES_DOC: sorted(CV_ECODES_DOC_LIST, key=lambda tup: tup[0]),
+ }
+
+