summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-yasnippet-fix-tests.patch
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2023-08-19 08:40:03 +0200
committerLiliana Marie Prikler <[email protected]>2023-08-19 08:43:37 +0200
commitca7e310f7ac32354b2e693e9a0f783320952a8fc (patch)
tree139e53068a569646fc284dac214d2ec2825dce0b /gnu/packages/patches/emacs-yasnippet-fix-tests.patch
parentf9b3bcac9ad64bdf43b2cdd8fd9ed74dec137590 (diff)
gnu: emacs-yasnippet: Fix build.
* gnu/packages/patches/emacs-yasnippet-fix-empty-snippet-next.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/emacs-xyz.scm (emacs-yasnippet)[source]<patches>: Use it here. * gnu/packages/patches/emacs-yasnippet-fix-tests.patch: Also fix delete-numberless-inner-snippet-issue-562.
Diffstat (limited to 'gnu/packages/patches/emacs-yasnippet-fix-tests.patch')
-rw-r--r--gnu/packages/patches/emacs-yasnippet-fix-tests.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-yasnippet-fix-tests.patch b/gnu/packages/patches/emacs-yasnippet-fix-tests.patch
index c70cc75d92..5995b0afa4 100644
--- a/gnu/packages/patches/emacs-yasnippet-fix-tests.patch
+++ b/gnu/packages/patches/emacs-yasnippet-fix-tests.patch
@@ -10,6 +10,11 @@ Content-Transfer-Encoding: 8bit
- A test that was temporarily broken passes again.
- The default for ‘org-adapt-indentation’ has changed.
- buffer-list may be called with arguments when native-comp is enabled.
+
+2023-08-19 Liliana Marie Prikler <[email protected]>
+
+ * delete-numberless-inner-snippet-issue-562: Correct value in
+ looking-at.
---
yasnippet-tests.el | 45 ++++++++++++++++++++++++++++-----------------
1 file changed, 28 insertions(+), 17 deletions(-)
@@ -26,6 +31,15 @@ index f7ca2bb..7618ab7 100644
;; Author: João Távora <[email protected]>
;; Keywords: emulations, convenience
+@@ -289,7 +289,7 @@ attention to case differences."
+ (should (looking-at "testblable"))
+ (ert-simulate-command '(yas-next-field-or-maybe-expand))
+ (ert-simulate-command '(yas-skip-and-clear-field))
+- (should (looking-at "ble"))
++ (should (looking-at "blable"))
+ (should (null (yas-active-snippets)))))
+
+ (ert-deftest delete-nested-simple-field-issue-824 ()
@@ -556,16 +556,19 @@ XXXXX ------------------------"))))
(yas-mock-insert "foo bar")
(ert-simulate-command '(yas-next-field))