summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2020-11-10 17:49:14 +0100
committerLudovic Courtès <[email protected]>2020-11-10 17:49:14 +0100
commit8515ea12d283632e7d0103286e679542d896058b (patch)
tree5c71f09864a027b13a6cb3c236c1079608f639c1 /gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
parent74361d3ee8c1524ee3f3496f113b9a8bf644e023 (diff)
gnu: audiofile: Shorten patch file names.
At least 'audiofile-division-by-zero-BlockCodec-runPull.patch' could end up not being included in a tarball. * gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch: Rename to... * gnu/packages/patches/audiofile-check-number-of-coefficients.patch: ... this. * gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch: Rename to... * gnu/packages/patches/audiofile-division-by-zero.patch: ....this. * gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: Rename to... * gnu/packages/patches/audiofile-function-signature.patch: ... this. * gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch: Rename to.... * gnu/packages/patches/audiofile-multiply-overflow.patch: ... this. * gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch: Rename to... * gnu/packages/patches/audiofile-overflow-in-MSADPCM.patch: ... this. * gnu/packages/audio.scm (audiofile)[source]: Adjust accordingly. * gnu/local.mk (dist_patch_DATA): Likewise.
Diffstat (limited to 'gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch')
-rw-r--r--gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch b/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
deleted file mode 100644
index f9427cbe61..0000000000
--- a/gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From: Antonio Larrosa <[email protected]>
-Date: Mon, 6 Mar 2017 12:51:22 +0100
-Subject: Always check the number of coefficients
-
-When building the library with NDEBUG, asserts are eliminated
-so it's better to always check that the number of coefficients
-is inside the array range.
-
-This fixes the 00191-audiofile-indexoob issue in #41
----
- libaudiofile/WAVE.cpp | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/libaudiofile/WAVE.cpp b/libaudiofile/WAVE.cpp
-index 9dd8511..0fc48e8 100644
---- a/libaudiofile/WAVE.cpp
-+++ b/libaudiofile/WAVE.cpp
-@@ -281,6 +281,12 @@ status WAVEFile::parseFormat(const Tag &id, uint32_t size)
-
- /* numCoefficients should be at least 7. */
- assert(numCoefficients >= 7 && numCoefficients <= 255);
-+ if (numCoefficients < 7 || numCoefficients > 255)
-+ {
-+ _af_error(AF_BAD_HEADER,
-+ "Bad number of coefficients");
-+ return AF_FAIL;
-+ }
-
- m_msadpcmNumCoefficients = numCoefficients;
-