summaryrefslogtreecommitdiff
path: root/gnu/packages/orange.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-19 12:07:15 +0000
committerRicardo Wurmus <[email protected]>2025-01-20 21:38:05 +0100
commit69d657f9c4ffa59d708356baacbefafb58f09308 (patch)
treef7a7ced1fe380eba4b0e6e28ed332a72252f3e3f /gnu/packages/orange.scm
parentad595936b6c29fcc4e0391c8d7a406a9e232ea25 (diff)
gnu: python-orange-widget-base: Update to 4.25.1.
* gnu/packages/orange.scm (python-orange-widget-base): Update to 4.25.1. Use G-Expressions, fix build. [srouce]: Adjust URI as PyPI archive name has been changed. [build-system]: Swap to pyproject-build-system. [arguments] <tests?>: Enable them. <test-flags>: Skipp 3 failing tests. <phases>: Remove 'check-setup, add 'pre-check. [native-inputs]: Add python-pytest, python-setuptools, python-trubar, and python-wheel. Change-Id: I20db769c92ec67263984c79ee77e430fd35712ae
Diffstat (limited to 'gnu/packages/orange.scm')
-rw-r--r--gnu/packages/orange.scm46
1 files changed, 31 insertions, 15 deletions
diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
index 00090064da..9cc1f29767 100644
--- a/gnu/packages/orange.scm
+++ b/gnu/packages/orange.scm
@@ -99,27 +99,43 @@ data-mining application.")
(define-public python-orange-widget-base
(package
(name "python-orange-widget-base")
- (version "4.16.1")
+ (version "4.25.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "orange-widget-base" version))
+ (uri (pypi-uri "orange_widget_base" version))
(sha256
- (base32 "0a0sijsvzijj71sxq8ckpgz59z1cq9sxn4fya3z23ibdzjzwrsi7"))))
- (build-system python-build-system)
+ (base32 "1vms6bf96dnx5ban30xd0r0ipc318iq9q2wwgnazphf4hic8vxzi"))))
+ (build-system pyproject-build-system)
(arguments
- `(;; unittest fails to load one test, all other tests are passing:
- ;; AttributeError: module 'orangewidget' has no attribute 'version'.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "HOME" "/tmp")
- (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (list
+ #:test-flags
+ #~(list "-k" (string-join
+ (list
+ ;; KeyError: 'HTML (*.html)'
+ "not test_save_report_html"
+ ;; KeyError: 'PDF (*.pdf)'
+ "test_save_report_pdf"
+ ;; AssertionError: False is not true
+ "test_menu")
+ " and not "))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (native-inputs
+ (list python-pytest
+ python-setuptools
+ python-trubar
+ python-wheel))
(propagated-inputs
- (list python-anyqt python-matplotlib python-orange-canvas-core
- python-pyqtgraph python-typing-extensions))
+ (list python-anyqt
+ python-matplotlib
+ python-orange-canvas-core
+ python-pyqtgraph
+ python-typing-extensions))
(home-page "https://github.com/biolab/orange-widget-base")
(synopsis "Base Widget for Orange Canvas")
(description