summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-26 20:55:06 +0000
committerSharlatan Hellseher <[email protected]>2025-01-26 20:55:06 +0000
commit75437dbb7695bf336e349796f075df06662b130c (patch)
treef9be05fb167d6405297f9f5db1196c73b9795edc /gnu/packages/networking.scm
parent55859a28cc1deeddb2d7e46c3a4579290029501b (diff)
parent9e2de68cf8aa5ac590ae3fca4fe90ac1b91bfa8a (diff)
Merge remote-tracking branch 'origin/go-team'
Change-Id: I3672a7dc248a41b1a83e4c488523f62cf1806710
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm54
1 files changed, 12 insertions, 42 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f50d4c81b2..970a502b59 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1952,41 +1952,6 @@ manage, and delete Internet resources from Gandi.net such as domain names,
virtual machines, and certificates.")
(license license:gpl3+)))
-(define-public go-github-com-vishvananda-netns
- (package
- (name "go-github-com-vishvananda-netns")
- (version "0.0.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vishvananda/netns")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0rci8c211m57nya9il81fz6459pia3dj5i4b16fp34vjrkcxliml"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/vishvananda/netns"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; Disable tests requiring root access.
- (("TestGetNewSetDelete") "OffTestGetNewSetDelete")
- (("TestThreaded") "OffTestThreaded"))))))))
- (propagated-inputs
- (list go-golang-org-x-sys))
- (home-page "https://github.com/vishvananda/netns")
- (synopsis "Simple network namespace handling for Go")
- (description
- "The netns package provides a simple interface for handling network
-namespaces in Go.")
- (license license:asl2.0)))
-
(define-public go-sctp
;; docker-libnetwork-cmd-proxy requires this exact commit.
;; This commit is mentioned in docker-libnetwork-cmd-proxy's vendor.conf.
@@ -4790,7 +4755,7 @@ IPv6 Internet connectivity - it also works over IPv4.")
(define-public nebula
(package
(name "nebula")
- (version "1.9.3")
+ (version "1.9.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4799,7 +4764,7 @@ IPv6 Internet connectivity - it also works over IPv4.")
(file-name (git-file-name name version))
(sha256
(base32
- "08zzbx2v713zd9p7i4kd1bvcw47xb0092p5apba1x5wg6fpxw5zr"))
+ "1slknnrdnf5a2ask11ql3gwnnl6c5359bp8rd712aq30lxa2d4r0"))
;; Remove windows-related binary blobs and files
(snippet
#~(begin
@@ -4811,6 +4776,8 @@ IPv6 Internet connectivity - it also works over IPv4.")
(list
#:import-path "github.com/slackhq/nebula"
#:install-source? #f
+ ;; XXX: Pack missing packages for cmd/nebula-service
+ #:test-subdirs #~(list ".")
#:phases
#~(modify-phases %standard-phases
(replace 'build
@@ -4837,29 +4804,32 @@ IPv6 Internet connectivity - it also works over IPv4.")
(list go-dario-cat-mergo
go-github-com-anmitsu-go-shlex
go-github-com-armon-go-radix
- go-github-com-cespare-xxhash-v2
go-github-com-cyberdelia-go-metrics-graphite
go-github-com-flynn-noise
+ go-github-com-gaissmai-bart
go-github-com-gogo-protobuf
go-github-com-google-gopacket
+ go-github-com-kardianos-service
go-github-com-miekg-dns
go-github-com-nbrownus-go-metrics-prometheus
go-github-com-prometheus-client-golang
- go-github-com-prometheus-client-model
- go-github-com-prometheus-procfs
go-github-com-rcrowley-go-metrics
go-github-com-sirupsen-logrus
go-github-com-skip2-go-qrcode
go-github-com-songgao-water
go-github-com-stretchr-testify
+ go-github-com-vishvananda-netlink
go-golang-org-x-crypto
+ go-golang-org-x-exp
go-golang-org-x-net
+ go-golang-org-x-sync
go-golang-org-x-sys
go-golang-org-x-term
+ go-golang-zx2c4-com-wireguard
go-google-golang-org-protobuf
go-gopkg-in-yaml-v2
- go-github-com-vishvananda-netlink
- go-github-com-vishvananda-netns))
+ ;go-gvisor-dev-gvisor ; for nebula-service, not packed yet
+ ))
(home-page "https://github.com/slackhq/nebula")
(synopsis "Scalable, peer-to-peer overlay networking tool")
(description