summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-02-06 15:08:45 +0200
committerEfraim Flashner <[email protected]>2025-02-06 16:03:45 +0200
commit782cc91970a795a58d10391f387cc12e4bfd1c90 (patch)
tree74740ae626c8bdf5935578076495f0e45bdfd433 /gnu/packages/man.scm
parent3f76813d82530303881ffdac87de29da92eef880 (diff)
gnu: man-db: Fix building for non-linux systems.
* gnu/packages/man.scm (man-db)[inputs]: Only include libseccomp when building for a linux system. Change-Id: I7e565a5ef92d148b91678c3d1bc0889f27aa5163
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 1ff1fac991..54e436a1eb 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014 David Thompson <[email protected]>
;;; Copyright © 2015, 2016 Ricardo Wurmus <[email protected]>
;;; Copyright © 2015 Alex Kost <[email protected]>
-;;; Copyright © 2015, 2016, 2020 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2020, 2025 Efraim Flashner <[email protected]>
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2018, 2019 Rutger Helling <[email protected]>
;;; Copyright © 2018, 2019, 2022 Marius Bakke <[email protected]>
@@ -202,13 +202,16 @@ a flexible and convenient way.")
;; Groff is needed at build time for troff, grops, soelim, etc.
groff))
(inputs
- (list gdbm
- groff-minimal
- less
- libpipeline
- libseccomp
- util-linux
- zstd))
+ (append
+ (list gdbm
+ groff-minimal
+ less
+ libpipeline)
+ (if (target-linux?)
+ (list libseccomp)
+ '())
+ (list util-linux
+ zstd)))
(native-search-paths
(list (search-path-specification
(variable "MANPATH")