summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
committerMaxim Cournoyer <[email protected]>2021-10-01 17:10:49 -0400
commit2e65e4834a226c570866f2e8976ed7f252b45cd1 (patch)
tree21d625bce8d03627680214df4a6622bf8eb79dc9 /gnu/packages/man.scm
parent9c68ecb24dd1660ce736cdcdea0422a73ec318a2 (diff)
parentf1a3c11407b52004e523ec5de20d326c5661681f (diff)
Merge remote-tracking branch 'origin/master' into staging
With resolved conflicts in: gnu/packages/bittorrent.scm gnu/packages/databases.scm gnu/packages/geo.scm gnu/packages/gnupg.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/linux.scm gnu/packages/python-xyz.scm gnu/packages/xorg.scm guix/build/qt-utils.scm
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 8911463a61..7db3da2bb7 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -225,14 +225,14 @@ the traditional flat-text whatis databases.")
(define-public mandoc
(package
(name "mandoc")
- (version "1.14.5")
+ (version "1.14.6")
(source (origin
(method url-fetch)
(uri (string-append "https://mandoc.bsd.lv/snapshots/mandoc-"
version ".tar.gz"))
(sha256
(base32
- "1xyqllxpjj1kimlipx11pzyywf5c25i4wmv0lqm7ph3gnlnb86c2"))))
+ "174x2x9ws47b14lm339j6rzm7mxy1j3qhh484khscw0yy1qdbw4b"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "regress"
@@ -254,6 +254,10 @@ the traditional flat-text whatis databases.")
"\n"))))))))
(native-inputs `(("perl" ,perl))) ;used to run tests
(inputs `(("zlib" ,zlib)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "MANPATH")
+ (files '("share/man")))))
(synopsis "Tools for BSD mdoc and man pages")
(description
"mandoc is a suite of tools compiling mdoc, the roff macro language of
@@ -269,7 +273,7 @@ PostScript, and PDF. Additional tools include the @command{man} viewer, and
(define-public man-pages
(package
(name "man-pages")
- (version "5.11")
+ (version "5.13")
(source
(origin
(method url-fetch)
@@ -279,7 +283,7 @@ PostScript, and PDF. Additional tools include the @command{man} viewer, and
(string-append "mirror://kernel.org/linux/docs/man-pages/Archive/"
"man-pages-" version ".tar.xz")))
(sha256
- (base32 "1aiwn6yi19idg4jbf7x4x5i06macjv7r8d5fgp1rwnc4a775vniy"))))
+ (base32 "12vb15gs56g8wl5nqlm4llr508brh4m2lfknhq4lizbxzqzawkb1"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases (delete 'configure))
@@ -290,7 +294,7 @@ PostScript, and PDF. Additional tools include the @command{man} viewer, and
#:parallel-build? #f
#:tests? #f
- #:make-flags (list (string-append "MANDIR="
+ #:make-flags (list (string-append "mandir="
(assoc-ref %outputs "out")
"/share/man"))))
(home-page "https://www.kernel.org/doc/man-pages/")