summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-03-02 08:07:11 +0100
committerLiliana Marie Prikler <[email protected]>2024-03-02 08:07:11 +0100
commit3d4fc910f73220f47e5f2459853333a7c83c5d1d (patch)
treed3178f93b78b3629dc7067cef69cf2a95490966d /gnu/packages/lisp.scm
parent9160cccd767cdfa55f7a460750c6b0f7544c12eb (diff)
parent4a0549be52f3f46fbce61342d8de30f7b83130c5 (diff)
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4f89779d8d..c58e56b7a7 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -25,7 +25,8 @@
;;; Copyright © 2022 ( <[email protected]>
;;; Copyright © 2023 Zheng Junjie <[email protected]>
;;; Copyright © 2023 Yovan Naumovski <[email protected]>
-;;; Copyright © 2023 Andrew Kravchuk <[email protected].
+;;; Copyright © 2023 Andrew Kravchuk <[email protected]>
+;;; Copyright © 2024 Andreas Enge <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1241,7 +1242,7 @@ including a built-in database engine and a GUI system.")
(define-public janet
(package
(name "janet")
- (version "1.32.1")
+ (version "1.33.0")
(source
(origin
(method git-fetch)
@@ -1250,7 +1251,7 @@ including a built-in database engine and a GUI system.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nnqbpql6749597m0lp56i2zqm003pg690399l0g8kb9kwvpv1yv"))))
+ (base32 "16wgljca7hp29fz5p2dnvy2cbscjx4imf85rhjwc1jkgdjswjxli"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
@@ -1488,12 +1489,12 @@ includes a compiler as well as an interpreter.")
(define-public s7-bootstrap
;; Need s7-bootstrap to build libc_s7.so (for the REPL) and run tests
- (let ((commit "618de30e0f9851515724245e3ebbfa1be4de6906") ;no releases
+ (let ((commit "23a64facfac06c4bc23a7de8f04691c55f88bd40") ;no releases
(revision "0"))
(hidden-package
(package
(name "s7-bootstrap")
- (version (git-version "23.3" revision commit))
+ (version (git-version "24.1" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1502,7 +1503,8 @@ includes a compiler as well as an interpreter.")
(file-name (git-file-name name version))
(sha256
(base32
- "0kh1f49g24ppjpr16v1nc9lr7pvr5nzb82bpw8c6q8ll7pqalqaf"))))
+ "0fiw8lb7rswglixvn271la2q2hgwszrf2ckykhr6jjxdvmb9a7d0"))
+ (patches (search-patches "s7-flint-3.patch"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ;no tests in bootstrap
@@ -1533,7 +1535,7 @@ includes a compiler as well as an interpreter.")
(invoke #$(cc-for-target) "libarb_s7.c"
"-I." "-O2" "-g"
"-shared" "-o" "libarb_s7.so"
- "-larb" "-lflint" "-lmpc" "-fPIC")
+ "-lflint" "-lmpc" "-fPIC")
(display "[BUILD] libnotcurses_s7.so\n")
(invoke #$(cc-for-target) "notcurses_s7.c"
"-I." "-O2" "-g"
@@ -1572,7 +1574,7 @@ includes a compiler as well as an interpreter.")
(install-file "s7.c" share)
(install-file "s7.h" inc)
(install-file "s7.html" doc)))))))
- (inputs (list arb flint mpc notcurses))
+ (inputs (list flint mpc notcurses))
(home-page "https://ccrma.stanford.edu/software/snd/snd/s7.html")
(synopsis "Scheme interpreter intended as an extension language")
(description