summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorJosselin Poiret <[email protected]>2023-06-02 21:59:48 +0200
committerJosselin Poiret <[email protected]>2023-06-04 10:33:59 +0200
commitb741218e919bfd386772322c1dcb286446bc4c90 (patch)
tree06843c4e530f097c5216d938ad1f98a2f0a4214f /gnu/packages/linux.scm
parentd89247150fe6e97c2fceed8d578fd119a782624d (diff)
gnu: proot: Update to 5.4.0 and fix clone3 behavior.
* gnu/packages/patches/proot-add-clone3.patch: New patch. * gnu/packages/linux.scm (proot): Update to 5.4.0, and add pending upstream patch to fix buggy pthread support. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index fc6f3cbda5..501ac9d19c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8159,7 +8159,7 @@ Text-based output formats: CSV, XML, Netfilter's LOG, Netfilter's conntrack
(define-public proot
(package
(name "proot")
- (version "5.3.0")
+ (version "5.4.0")
(source
(origin
(method git-fetch)
@@ -8168,7 +8168,10 @@ Text-based output formats: CSV, XML, Netfilter's LOG, Netfilter's conntrack
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1r1ga3xbwq5kx4i8ihj1p6nmgaa14lfkwxzpsbdcmfh1jimpbmzk"))))
+ (base32 "186qsg4yvisqjgf8w5jxhnlig7x341vpqwcgp8as3r59qmqkpmk7"))
+ ;; Waiting for upstream inclusion at
+ ;; https://github.com/proot-me/proot/pull/355
+ (patches (search-patches "proot-add-clone3.patch"))))
(build-system gnu-build-system)
;; Many architectures are not supported (see:
;; https://github.com/proot-me/proot/blob/master/src/arch.h#L51).