summaryrefslogtreecommitdiff
path: root/gnu/packages/libusb.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 16:24:31 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commit56fbdee16c4757dddb96b3d3c483c5f61026f14c (patch)
treed983672c488eadca5e251648513a0eabceba9922 /gnu/packages/libusb.scm
parentaea7f8ee407a27ce0cec792bb3cf301fe13ddf29 (diff)
gnu: python-hidapi: Update to 0.14.0.post2.
* gnu/packages/libusb.scm (python-hidapi): Update to 0.14.0.post2. [native-inputs]: Add pkg-config. Change-Id: I07709234bb9946587aa3696fa8a1d7ecc321a35f
Diffstat (limited to 'gnu/packages/libusb.scm')
-rw-r--r--gnu/packages/libusb.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index a2bdda6057..a6e24f8c41 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -752,14 +752,14 @@ HID-Class devices.")
(define-public python-hidapi
(package
(name "python-hidapi")
- (version "0.7.99.post21")
+ (version "0.14.0.post2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hidapi" version))
(sha256
(base32
- "15ws59zdrxahf3k7z5rcrwc4jgv1307anif8ixm2cyb9ask1mgp0"))
+ "1b2q4kpzvfbbdy5xjh5nas3ymg7gspqai5dla6fk16h5dfx9f3kc"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.
@@ -795,7 +795,7 @@ HID-Class devices.")
(inputs
(list hidapi libusb eudev))
(native-inputs
- (list python-cython))
+ (list python-cython pkg-config))
(home-page "https://github.com/trezor/cython-hidapi")
(synopsis "Cython interface to hidapi")
(description "This package provides a Cython interface to @code{hidapi}.")