summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-games.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2025-02-28 22:11:42 +0900
committerMaxim Cournoyer <[email protected]>2025-02-28 22:19:03 +0900
commit73ceab22af8c0c35b4f89d75740c6b745f8d9ba6 (patch)
tree9760e7144af33af13f96f4df530307c171f5237c /gnu/packages/kde-games.scm
parent262d66f71b23ddb192a64768d4610c17f88124dd (diff)
gnu: kigo: Patch default gnugo command.
So that it works out of the box, without further user installation or configuration. * gnu/packages/kde-games.scm (kigo) [arguments] <#:phases>: New argument. [inputs]: Add gnugo. [description]: Remove mention of 'open-source'. Remove obsolete mention of installing the 'gnugo' package separately. Change-Id: I940e4618da2a382874682c061fb9d27bab825b3f
Diffstat (limited to 'gnu/packages/kde-games.scm')
-rw-r--r--gnu/packages/kde-games.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index 98f740150d..b0f00b1c93 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017, 2019 Hartmut Goebel <[email protected]>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Efraim Flashner <[email protected]>
;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <[email protected]>
-;;; Copyright © 2021 Maxim Cournoyer <[email protected]>
+;;; Copyright © 2021, 2025 Maxim Cournoyer <[email protected]>
;;; Copyright © 2019, 2020, 2021 Guillaume Le Vaillant <[email protected]>
;;; Copyright © 2022 Brendan Tildesley <[email protected]>
;;; Copyright © 2022 Petr Hodina <[email protected]>
@@ -32,6 +32,7 @@
#:use-module (guix gexp)
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages games)
#:use-module (gnu packages gl)
#:use-module ((gnu packages freedesktop) #:select (shared-mime-info))
#:use-module (gnu packages kde)
@@ -1098,10 +1099,22 @@ This package is part of the KDE games module.")
(sha256
(base32 "1ha4ywihk7wf1cqqbjq6j2pr3x43xxna5nz0x21msiq37rrx93j0"))))
(build-system qt-build-system)
+ (arguments
+ (list
+ #:qtbase qtbase
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-gnugo-command
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/kigo.kcfg"
+ (("\"gnugo\"")
+ (format #f "~s"
+ (search-input-file inputs "bin/gnugo")))))))))
(native-inputs
- (list extra-cmake-modules kdoctools))
+ (list extra-cmake-modules
+ kdoctools))
(inputs
- (list kconfig
+ (list gnugo
+ kconfig
kconfigwidgets
kcoreaddons
kcrash
@@ -1114,11 +1127,9 @@ This package is part of the KDE games module.")
libkdegames
qtdeclarative
qtsvg))
- (arguments (list #:qtbase qtbase))
(home-page "https://apps.kde.org/kigo/")
(synopsis "Go board game")
- (description "Kigo is an open-source implementation of the popular Go
-game.
+ (description "Kigo is an implementation of the popular Go game.
Go is a strategic board game for two players. It is also known as
igo (Japanese), weiqi or wei ch'i (Chinese) or baduk (Korean). Go is noted
@@ -1127,8 +1138,6 @@ played by two players who alternately place black and white stones (playing
pieces, now usually made of glass or plastic) on the vacant intersections of a
grid of 19x19 lines (9x9 or 13x13 for easier games).
-You also need to install a go engine, e.g. @code{gnugo}.
-
This package is part of the KDE games module.")
(license license:gpl3+)))