summaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <[email protected]>2024-01-23 11:19:47 -0500
committerLudovic Courtès <[email protected]>2024-08-31 10:44:42 +0200
commit2e4e3e883b6feea74da2f528cee0af417f16d982 (patch)
treeb281bfc37d622f180bdc19cdcc820bc1a834ade5 /gnu/packages/imagemagick.scm
parentf5d75acd0dd047887ac7e80af17e9d03f3ff571b (diff)
gnu: imagemagick: Update to 6.9.13-5.
This is a follow-up to ac658511ae ("gnu: imagemagick: Update to 6.9.12-91."), which patch didn't apply cleanly. * gnu/packages/imagemagick.scm (imagemagick/stable): Update to 6.9.13-5. [source]: Remove patch. [configure-flags]: Specify correct --with-gs-font-dir location. [native-inputs]: Add zstd. * gnu/packages/patches/imagemagick-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.13-5. Change-Id: Ic3ab5ea821de91fb18b80325414444e02e7eecb0
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index cf6b6d5135..884fa87555 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -65,23 +65,25 @@
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-91")
+ (version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
- (patches
- (search-patches "imagemagick-fix-tests.patch"))))
+ "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))
(build-system gnu-build-system)
(arguments
(list
- #:configure-flags #~(list "--with-frozenpaths" "--without-gcc-arch"
-
- ;; Do not embed the build date in binaries.
- "--enable-reproducible-build")
+ #:configure-flags
+ #~(list "--with-frozenpaths"
+ "--without-gcc-arch"
+ (string-append "--with-gs-font-dir="
+ (search-input-directory %build-inputs
+ "share/fonts/type1"))
+ ;; Do not embed the build date in binaries.
+ "--enable-reproducible-build")
#:phases
#~(modify-phases %standard-phases
(add-before 'build 'pre-build
@@ -124,8 +126,11 @@
libxml2
pango
xz
- zlib))
- (native-inputs (list pkg-config))
+ zlib
+ zstd))
+ (native-inputs
+ (list font-ghostscript
+ pkg-config))
(outputs '("out"
"doc")) ; 26 MiB of HTML documentation
(home-page "https://www.imagemagick.org/")
@@ -146,16 +151,14 @@ text, lines, polygons, ellipses and Bézier curves.")
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-91")
+ (version "6.9.13-5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "0didbs10i9zb4dgripa851j7fivxb9jar7l3vvxz6i4kn6xvdv7r"))
- (patches
- (search-patches "imagemagick-fix-tests.patch"))))))
+ "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))))
(define-public perl-image-magick
(package