summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorBonfaceKilz <[email protected]>2021-01-26 13:42:32 +0300
committerEfraim Flashner <[email protected]>2021-01-27 11:20:50 +0200
commit3968722b7978c1834affbd9a4b3ad3dde62bc776 (patch)
tree0d31ccdf8d86e1b25e37340e44779b4b388316da /gnu/packages/guile-xyz.scm
parentfa3461428140532283f6133ec599d6e7afabe5f8 (diff)
gnu: guile-redis: Update to 2.0.0.
* gnu/packages/guile-xyz.scm (guile-redis): Update to 2.0.0. (guile2.0-redis)[arguments]: Add phase to adjust module imports. This patch was co-authored with Efraim Flashner. Signed-off-by: Efraim Flashner <[email protected]>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c2d853f006..0526cf8ad8 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Alex Sassmannshausen <[email protected]>
;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <[email protected]>
;;; Copyright © 2016 Erik Edrosa <[email protected]>
-;;; Copyright © 2016, 2019, 2020 Eraim Flashner <[email protected]>
+;;; Copyright © 2016, 2019, 2020, 2021 Eraim Flashner <[email protected]>
;;; Copyright © 2016, 2017 Alex Kost <[email protected]>
;;; Copyright © 2016, 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <[email protected]>
;;; Copyright © 2016 Amirouche <[email protected]>
@@ -33,6 +33,7 @@
;;; Copyright © 2020 Mike Rosset <[email protected]>
;;; Copyright © 2020 Leo Prikler <[email protected]>
;;; Copyright © 2020 pukkamustard <[email protected]>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2430,7 +2431,7 @@ interface for reading articles in any format.")
(define-public guile-redis
(package
(name "guile-redis")
- (version "1.3.0")
+ (version "2.0.0")
(home-page "https://github.com/aconchillo/guile-redis")
(source (origin
(method git-fetch)
@@ -2440,7 +2441,7 @@ interface for reading articles in any format.")
(file-name (git-file-name name version))
(sha256
(base32
- "14izs8daxh7pb7vwpxi5g427qa31137jkaxrb1cy5rpjkwchy723"))))
+ "1zk2x37lw6ygf7rwy71svnsian8lj51axpxmm66ah7dazn69swlm"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2464,6 +2465,18 @@ key-value cache and store.")
(package
(inherit guile-redis)
(name "guile2.0-redis")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ ;; put-string is in (rnrs io ports) in guile2.0,
+ ;; not in (ice-9 textual-ports)
+ (substitute* "redis/utils.scm"
+ (("\\(ice-9 textual-ports\\)")
+ "(rnrs io ports)"))
+ #t)))
+ ,@(package-arguments guile-redis)))
(native-inputs `(("guile" ,guile-2.0)
,@(alist-delete "guile"
(package-native-inputs guile-redis))))))