summaryrefslogtreecommitdiff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-17 21:26:59 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:26 +0000
commit92c4bedf07393cbf30e5c5214d781105af5c8150 (patch)
tree9e24ba4ab9693f63053b9a5cef6b7211ad64bb86 /gnu/packages/graphviz.scm
parentfd75f170432e8ae3a466aecd0c8e746825ef7e7c (diff)
gnu: python-graphviz: Update to 0.20.3.
* gnu/packages/graphviz.scm (python-graphviz): Update to 0.20.3. [arguments]<phases>: Remove 'prepare-chec phase. Add 'patch-pytest-options phase. Use custom 'check phase. Change-Id: I8ebd1277e9b53b3ad267f567c449e6efc01b0653
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 10fde9c943..defd53df73 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -138,21 +138,28 @@ interfaces for other technical domains.")
(define-public python-graphviz
(package
(name "python-graphviz")
- (version "0.20.1")
+ (version "0.20.3")
(source (origin
(method url-fetch)
(uri (pypi-uri "graphviz" version ".zip"))
(sha256
(base32
- "1y1b956r01kg7qarkkrivhn71q64k0gbq6bcybd4gfd3v95g2n4c"))))
+ "0pcjnnhprs1hb4r9jr7r4qjxc7lzsjlka8d5gcp3kym9ws0vrmh9"))))
(build-system pyproject-build-system)
(arguments
(list
#:phases
- '(modify-phases %standard-phases
- (add-before 'check 'prepare-chec
- ;; Needed for fontconfig cache directories
- (lambda _ (setenv "HOME" (getcwd)))))))
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'pathch-pytest-options
+ (lambda _
+ (substitute* "setup.cfg"
+ ((".*doctest.*") "")
+ (("--cov.*") ""))))
+ (replace 'check
+ (lambda* (#:key tests? test-flags #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (apply invoke "python" "run-tests.py" test-flags)))))))
(native-inputs
(list unzip
;; For tests.