summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 20:42:01 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:45 +0000
commitff9538022dd8e8481aef4b7e490298547ac01e23 (patch)
tree2985de920235770f520077ee30778c26be9206d9 /gnu/packages/golang.scm
parent7c7247efb01d197cb2ecdcd97f1ddab44a2977fa (diff)
gnu: go-github-com-jtolds-gls: Move to golang-check.
* gnu/packages/golang.scm (go-github-com-jtolds-gls): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ic4e483abf95146a3a39919f40e8dda86c64dd355
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2a4c8d3185..87edd0f04e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2142,38 +2142,6 @@ termination.")
"t.Fatalf(`Killf(\"BO%%s")))))))
(home-page "https://gopkg.in/tomb.v1")))
-(define-public go-github-com-jtolds-gls
- (package
- (name "go-github-com-jtolds-gls")
- (version "4.20.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jtolds/gls")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1k7xd2q2ysv2xsh373qs801v6f359240kx0vrl0ydh7731lngvk6"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/jtolds/gls"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (synopsis "@code{gls} provides Goroutine local storage")
- (description
- "The @code{gls} package provides a way to store a retrieve values
-per-goroutine.")
- (home-page "https://github.com/jtolds/gls")
- (license license:expat)))
-
(define-public gopls
(package
(name "gopls")