summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 14:31:48 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:43 +0000
commitd78e30019125cb83d0a3ff1513000c06c67d558e (patch)
tree2b3d69bd7b163eeba2314830c495f43c11f61483 /gnu/packages/golang.scm
parent4ca7437d6b9302477aa8adcafa4add94aa117222 (diff)
gnu: Remove go-github-com-imdario-mergo.
* gnu/packages/golang.scm (go-github-com-imdario-mergo): Delete variable. (go-dario-cat-mergo): Override go-github-com-imdario-mergo's package definition instead of inherit it. [source] <url>: Fix permament redirection <https://github.com/imdario/mergo> -> <https://github.com/darccio/mergo>. [native-inputs]: Remove go-gopkg-in-yaml-v2; add go-gopkg-in-yaml-v3. [home-page]: Fix permament redirection <https://github.com/imdario/mergo> -> <https://github.com/darccio/mergo>. Change-Id: I612c7d028a92e877fd20900dffaba267405d99e6
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm37
1 files changed, 8 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 570d8dcbf5..b7e0f7d459 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3202,25 +3202,25 @@ Porter2 stemmer}. It is written completely using finite state machines to do
suffix comparison, rather than the string-based or tree-based approaches.")
(license license:asl2.0))))
-(define-public go-github-com-imdario-mergo
+(define-public go-dario-cat-mergo
(package
- (name "go-github-com-imdario-mergo")
- (version "0.3.10")
+ (name "go-dario-cat-mergo")
+ (version "1.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/imdario/mergo")
+ (url "https://github.com/darccio/mergo")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "09h765p8yby9r8s0a3hv5kl8n2i382mda76wmvk48w1cc1w9s92p"))))
+ "037k2bd97vnbyhn2sczxk0j6ijmv06n1282f76i3ky73s3qmqnlf"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/imdario/mergo"))
+ `(#:import-path "dario.cat/mergo"))
(native-inputs
- (list go-gopkg-in-yaml-v2))
- (home-page "https://github.com/imdario/mergo/")
+ (list go-gopkg-in-yaml-v3))
+ (home-page "https://github.com/darccio/mergo")
(synopsis "Helper to merge structs and maps in Golang")
(description "Helper to merge structs and maps in Golang. Useful for
configuration default values, avoiding messy if-statements.
@@ -3231,27 +3231,6 @@ recursively any exported one. It also won't merge structs inside
maps (because they are not addressable using Go reflection).")
(license license:bsd-3)))
-(define-public go-dario-cat-mergo
- (package
- (inherit go-github-com-imdario-mergo)
- (name "go-dario-cat-mergo")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/imdario/mergo")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "037k2bd97vnbyhn2sczxk0j6ijmv06n1282f76i3ky73s3qmqnlf"))))
- (build-system go-build-system)
- (arguments
- `(#:unpack-path "dario.cat/mergo"
- #:import-path "dario.cat/mergo"))
- (native-inputs
- (list go-gopkg-in-yaml-v3))))
-
(define-public go-github-com-olekukonko-ts
(let ((commit "78ecb04241c0121483589a30b0814836a746187d")
(revision "0"))