summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2023-11-29 22:35:17 +0000
committerMaxim Cournoyer <[email protected]>2024-01-03 16:35:20 -0500
commitd087261febf44b44936548849f155bc57680dadb (patch)
treeedbcf0751ebaf81309c8e2b49f309c5040006e4b /gnu/packages/golang.scm
parent7a9f0869d4677b553083f6439b673b95beae766c (diff)
gnu: go-github-com-francoispqt-gojay: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-francoispqt-gojay): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: I2ff041a91e2d37d79495a3ebda1b602784161c4a
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 40ffc1143d..beb14e0c3f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7479,31 +7479,6 @@ designed to clean up raw terminal output by stripping escape sequences,
optionally preserving color.")
(license license:expat)))
-(define-public go-github-com-francoispqt-gojay
- (package
- (name "go-github-com-francoispqt-gojay")
- (version "1.2.13")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/francoispqt/gojay")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/francoispqt/gojay"))
- (propagated-inputs
- (list go-github-com-stretchr-testify))
- (synopsis "JSON encoder/decoder with powerful stream API for Golang")
- (description "GoJay is a performant JSON encoder/decoder for Golang. It has
-a simple API and doesn't use reflection. It relies on small interfaces to
-decode/encode structures and slices.")
- (home-page "https://github.com/francoispqt/gojay")
- (license license:expat)))
-
(define-public go-github-com-pkg-errors
(package
(name "go-github-com-pkg-errors")