summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-10 21:12:23 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:55 +0000
commit79fcf255bdf5b73e293a403a94f2411eff09c484 (patch)
treecca7dbf576489e133be565a8288d14e64cd290e3 /gnu/packages/golang.scm
parent69c716a3937fb25862eb42c4a90cefe6328514f0 (diff)
gnu: Remove go-github-com-alcortesm-tgz.
Not in use by any packages in Guix, no updates for 9 years. * gnu/packages/golang.scm (go-github-com-alcortesm-tgz): Delete variable. Change-Id: I4a0e7dca27f435699a64a1e6f9598b920529d9db
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 976b3f3c74..ba00f9c593 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2589,42 +2589,6 @@ suffix comparison, rather than the string-based or tree-based approaches.")
size of the terminal.")
(license license:expat))))
-(define-public go-github-com-alcortesm-tgz
- (let ((commit "9c5fe88206d7765837fed3732a42ef88fc51f1a1")
- (revision "1"))
- (package
- (name "go-github-com-alcortesm-tgz")
- (version (git-version "0.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alcortesm/tgz")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "04dcwnz2c2i4wbq2vx3g2wrdgqpncr2r1h6p1k08rdwk4bq1h8c5"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (substitute* "tgz_test.go"
- ;; Fix format error
- (("t.Fatalf\\(\"%s: unexpected error extracting: %s\", err\\)")
- "t.Fatalf(\"%s: unexpected error extracting: %s\", com, err)"))
- #t))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/alcortesm/tgz"
- #:phases
- (modify-phases %standard-phases
- ;; Files are test fixtures, not generated.
- (delete 'reset-gzip-timestamps))))
- (home-page "https://github.com/alcortesm/tgz/")
- (synopsis "Go library to extract tgz files to temporal directories")
- (description "This package provides a Go library to extract tgz files to
-temporal directories.")
- (license license:expat))))
-
(define-public go-github-com-twpayne-go-vfsafero
(package
(name "go-github-com-twpayne-go-vfsafero")