summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-08 19:43:57 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:45 +0000
commit63ae00be2a4244ad6c2e00175d72687257088a90 (patch)
treefb9aebcada8c57c681404dbd9ce193922a6534ae /gnu/packages/golang.scm
parent9a88ba7802645a6d3637aeec08d227d5659ea70a (diff)
gnu: go-github-com-spaolacci-murmur3: Move to golang-crypto.
* gnu/packages/golang.scm (go-github-com-spaolacci-murmur3): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I05fca3251cf7706f8e34295657d57e43f1213079
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 91bb63417e..1ed230a19c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2622,32 +2622,6 @@ and lookup requests. Browse requests are not supported yet.")
(description "Go wrapper for taglib")
(license license:unlicense))))
-(define-public go-github-com-spaolacci-murmur3
- (package
- (name "go-github-com-spaolacci-murmur3")
- (version "1.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spaolacci/murmur3")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1lv3zyz3jy2d76bhvvs8svygx66606iygdvwy5cwc0p5z8yghq25"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/spaolacci/murmur3"))
- (home-page "https://github.com/spaolacci/murmur3")
- (synopsis "Native MurmurHash3 Go implementation")
- (description "Native Go implementation of Austin Appleby's third MurmurHash
-revision (aka MurmurHash3).
-
-Reference algorithm has been slightly hacked as to support the streaming mode
-required by Go's standard Hash interface.")
- (license license:bsd-3)))
-
(define-public go-github-com-sabhiram-go-gitignore
(let ((commit "525f6e181f062064d83887ed2530e3b1ba0bc95a")
(revision "1"))