summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-07 09:47:19 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-07 09:49:56 +0000
commitd743ff99069fc7c1bfdbc79c0d980fd178a361c9 (patch)
treefe7f48c5eca38e74c9567ee0aa5a6d4fb1d93091 /gnu/packages/golang-xyz.scm
parent4e482db2a9178f3f4af76103f7adada2c6a08678 (diff)
gnu: Add go-github-com-dgraph-io-ristretto-v2.
* gnu/packages/golang-xyz.scm (go-github-com-dgraph-io-ristretto-v2): New variable. Change-Id: I77ba7c6210906ebb6f36eadc24f6afd531315721
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 22478211b8..2ff1093cb4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4145,6 +4145,25 @@ supports concurrent serializable transactions.")
on throughput and hit ratio performance.")
(license (list license:asl2.0 license:expat))))
+(define-public go-github-com-dgraph-io-ristretto-v2
+ (package
+ (inherit go-github-com-dgraph-io-ristretto)
+ (name "go-github-com-dgraph-io-ristretto-v2")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dgraph-io/ristretto")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q65y9psk8vnrsjlmaqhc8l3fwpsh23wrr4cjz8jfnph45hhh4jk"))))
+ (arguments
+ (substitute-keyword-arguments
+ (package-arguments go-github-com-dgraph-io-ristretto)
+ ((#:import-path _) "github.com/dgraph-io/ristretto/v2")))))
+
(define-public go-github-com-dgryski-go-linebreak
(package
(name "go-github-com-dgryski-go-linebreak")