summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-11 13:45:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-21 23:47:57 +0000
commita242505baa4e8e236270ac99c0b39c66622697d3 (patch)
treecbad0b321248bdc366b35db63a45414f9c626939 /gnu/packages/golang-xyz.scm
parent04dc2c0ae014f9aa26724bc9174f76bd5b2abe8f (diff)
gnu: go-github-com-go-ini-ini: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-go-ini-ini): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I0c7defa973b0301de3064d53b6c6b502fca9ef95
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2ab5fc1750..01380e99e0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5448,6 +5448,30 @@ operations.")
(list
#:import-path "github.com/go-git/go-git-fixtures/v5"))))
+(define-public go-github-com-go-ini-ini
+ (package
+ (name "go-github-com-go-ini-ini")
+ (version "1.67.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-ini/ini")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vpzkjmrwp7bqqsijp61293kk2vn6lcck56j8m5y6ks6cf21lpap"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/go-ini/ini"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://gopkg.in/ini.v1")
+ (synopsis "INI file read and write functionality in Go")
+ (description
+ "This package provides INI file read and write functionality in Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-kit-log
(package
(name "go-github-com-go-kit-log")