summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-23 12:58:43 +0000
committerSharlatan Hellseher <[email protected]>2025-01-23 12:58:43 +0000
commit7b287dd8adddb1e5792a8c1d8b79d74d0d8474e5 (patch)
treeb2b00f48190d2f214db09aa690c58db46f762fe9 /gnu/packages/golang-xyz.scm
parent6e73a0d1c38446183f2e3b46645ef406bb6892f6 (diff)
gnu: go-github-com-cention-sany-utf7: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-cention-sany-utf7): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Icc752dc109f6a0b2e43e8b5846ee9f288d174402
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 23af389b25..1ff5f56f8d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2330,6 +2330,30 @@ tools using Go.")
variables into structs.")
(license license:expat)))
+(define-public go-github-com-cention-sany-utf7
+ (package
+ (name "go-github-com-cention-sany-utf7")
+ (version "0.0.0-20170124080048-26cad61bd60a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cention-sany/utf7")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jy15ryfcln1iwchrksqyrnyfy41gisymm4f9sr1d73ja029bznm"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/cention-sany/utf7"))
+ (propagated-inputs (list go-golang-org-x-text))
+ (home-page "https://github.com/cention-sany/utf7")
+ (synopsis "UTF-7 for Go")
+ (description
+ "The utf7 package provides support for the obsolete UTF-7 text
+encoding in Go.")
+ (license license:bsd-3)))
+
(define-public go-github-com-cespare-mph
(package
(name "go-github-com-cespare-mph")