summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorAshvith Shetty <[email protected]>2025-02-15 00:35:29 +0530
committerSharlatan Hellseher <[email protected]>2025-02-15 16:08:16 +0000
commit7b0c7da670352f48f680c03d06ecda5dda849d80 (patch)
treef6a8fe1695a8eeb75e7fd9187bb5fe147b74c43b /gnu/packages/golang-xyz.scm
parent21ff39ab1027c8c6d555ae076cf2d8c29d1c9843 (diff)
gnu: Add go-github-com-zyedidia-go-runewidth.
* gnu/packages/golang-xyz.scm (go-github-com-zyedidia-go-runewidth): New variable. Change-Id: I17b2b97f25fffaa0e0cff9be9cc43d1f83412bb2 Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ced28921e0..d903874fa0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16017,6 +16017,30 @@ Platforms supported:
"Package glob provides objects for matching strings with globs.")
(license license:expat)))
+(define-public go-github-com-zyedidia-go-runewidth
+ (hidden-package
+ (package
+ (inherit go-github-com-mattn-go-runewidth)
+ (name "go-github-com-zyedidia-go-runewidth")
+ (version "0.0.12")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zyedidia/go-runewidth")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "18gv5fkd69v8bwngj6r5zc572vyd1qhafz1wi3d7ynz3w0mmq85c"))))
+ (arguments
+ (list
+ #:import-path "github.com/zyedidia/go-runewidth"))
+ (home-page "https://github.com/zyedidia/go-runewidth")
+ (description
+ "It's an alternative fork of
+@url{https://github.com/mattn/go-runewidth}."))))
+
(define-public go-github-com-zyedidia-poller
(package
(name "go-github-com-zyedidia-poller")